RepetierHost v1.5.6 & Slic3r 1.2.9 on Linux - Configuration button not working

I'm running Linux Mint 17.1. I was running RepetierHost 1.0.6 with Slic3r 1.1.7.

I created a fresh install of Repetier Host 1.5.6 and untarred Slic3r 1.2.9 into the RepetierHost directory. When I select Slic3r as the slicer and click on the Configuration button it lists all the Slic3r options in the log window instead of opening the configuration window.

I ran the script and all my packages are up to date.

I tried removing my ~/.Slic3r directory will all my settings in it and it made no difference.

I tried removing the ~/.local/share/RepetierHost directory and it made no difference.



  • Further troubleshooting steps I have taken:

    I ran apt-get update && apt-get upgrade which upgraded a lot of packages. Still did not work.

    I removed the ~/.mono directory. This did change the behaviour of RepetierHost a little - it loaded some part on startup that I've never seen before. :)

    But the Configuration button for Slic3r still does not work.

    As an additional note, if I change the slicer to CuraEngine then the Configuration button works as expected.
  • Ah. Interesting. I downloaded Slic3r 1.1.7 and installed it instead. The configuration button works.

    Looks like RepeiterHost needs a little work to use Slic3r 1.2.9.

    Time to file a bug.
  • Have you tried starting slic3r directly? If it does not work due to missing libraries etc the host will not be able to call it. What is the message in the host when you call it. Should be visible in the log.
  • Thank you for that. It turns out that I did not have freeglut3 installed. Apparently that's a new requirement? Or maybe I didn't need it when I was running the 32 bit version of Slic3r.

    In any case, it's working now.
Sign In or Register to comment.