wrong date and time

the server says date is 6-10-2021 and time is one hour too late


  • Hour wrong happens if time zone is not set. Pi has no battery buffered clock so it needs internet connection to update time to be correct.

    In time tab there is a bug that it presents wrong day of month (0-6) - will be fixed in 1.0.5. This has no effect on the real time - see flash icon in main menu.
  • Hi,
    Actually, I have the same problem. The time is not correct, also time zone is completely wrong, I need to choose a zone 7 hours later than CEST to see kind of a right time, but also the minutes are wrong. However, it "just" doesn't work at server touch screen, in browser it works correctly.
    The server has full internet connection (Raspi 4). I also enabled all required ports in the router :( As far as I can say it worked in former version.
    Pls help.

    Many thanks in advance.
  • You see date from browser in touchscreen and that is the time from pi. We start in our image a network time query to fetch time based on time zone since pi does not buffer time. If you check the bolt icon in regular gui you see the time that the pi currently has and in which time zone it is working. With my images it seems to always work. But if there is a block in some firewall that block NTP requests it might not update. Not sure what else could cause it from not updating. Latest image uses the systemd ntp update function that is build in by default in default configuration.
  • Thx for the update. It is a regular FritzBox, IMHO there should not be a NTP blocker by default. Do you know how to check this in FritzBox?
    Many thanks
  • BTW, it is possible to use the FritzBox for NTP service. Where can I edit the IP address for the NTP server in the repetier server conf files?
  • sudo raspi-config
    don't work?
  • See
    for config file options. It is /etc/systemd/timesyncd.conf and contains only the fallback servers from default package. But you can point it to any ntp server.
Sign In or Register to comment.