Temperature reading doesn't update

Hi, Just a small problem. I recently updated to Repetier-Server 1.0.2 and had problems so I rolled back to 0.94.3. now I don't seem to get a constant temperature reading from the hotend or the bed, nothing in graph or anywhere else, it will read the temp once then doesn't update.
Using a Pi 3b connected to a Prusa MK3s, I tried again reinstalling t
sudo dpkg -i Repetier-Server-0.94.3-Linux.debsudo dpkg -i Repetier-Server-0.94.3-Linux.deb

Other than trying V1.0.3 any ideas ? Thanks



  • Not really. I see there are no entries so x axis has no titles. But why is the question. Please go to console enable ack and disable M105 filter. Then you should see temperature responses. If not run
    and see if they start coming. Prusa supports autoreport temperatures so we do not need to query.
    M155 S1
    activates it. It gets automatically activated when M115 reports the capability. I guess something is gone wrong here. Does this always happen when you deactivate and activate printer in server?
  • I enabled ack and disabled M105 filter still no updates. I then ran M115 graph and temp updates started working ? Is this permanent now? 
  • Could it be something to do with a recent Prusa FW Update? 
  • edited February 8
    Repetier said:
    Does this always happen when you deactivate and activate printer in server?
    IT just doesn’t happen in graph or temp status anywhere, just get one temp reading when Repetier connects with printer that’s it. 

    I’ve now run  M155 S1 I’m guessing this will trigger the Temperature Reporting permanently ? 

  • Just to let you know, I read in one of the Octoprint forms there was a similar issue to this caused by Marlin FW. Maybe this is the same problem in my case.

    I added M155 S1 to Run on Connect in Printer Settings>Event Dependent 

    Seems ok to me like this.....

    Can you see any problem doing this?
  • Since firmware supports the command that is no problem. As said normally we read it from Cap in M115 response and send it, but I guess for some reason it gets ignored at that time.
    Which firmware are you running? I'm currently on 3.9.1 I think.
  • edited February 9
    I’m using the latest from Bear Labs FW3.9.3 which is slightly modded from the Prusa MK3S version.

  • Ok so should be same as 3.9.1 in this regard and that works. So guess just something went wrong. But your solution should now make it double safe:-)
Sign In or Register to comment.