Z axis wont go any higher than 36.8

Bit of an odd one I will admit.

I and using Repetier Host as a controller for my Anet A8. Repetier seems to think that the max height (z axis) of the printer is approx 36.8. I found this out when i was printing my first tallish print and the z axis stopped going any higher half way through, but the print continued to try and print, but obviously was just spilling over that layer over and over again.

Slightly weird point is that repetier will let me go higher than 36.8 in controls, and this is reflected on the screen of my printer, but the actual z axis will move no more when setting the axis above 36.8.

I thought this might be a hardware issue, so brought the printer up to 36, turned the printer off and on, and then moved the z axis higher - this worked fine. I then homed the z anbd tried to bring to 37 and it again got stuck a 36 - for me this narrows that its an issue with repetier.

I have done all the usual things of checking the max z height is set correctly, tried changing this just in case, tried deleting and re adding the printer - nothing seems to change this magical number of 36.8.

Any help would be greatly appreciated :) I can share photos if it helps, and happy to answer any questions the best i can!


  • Host has only one setting for z max in Printer Settings->Printer Shape->Print Area Height - that is more to limit the up down buttons. Host will not forbid sending other Z heights to firmware directly. If you disable easy mode and enable commands you see what gets send to printer. So try e.g.
    G1 Z50
    and see if it moves. Ask firmware afterwards with
    where it thinks it is. If it did not move or reports 36.8 you have hit the limit in your printer configuration. Most firmwares can save z max in eeprom so check also eeprom settings for z max.
  • Hi Thanks for this, gave it a shot. The printer moved up but stopped at the same place as usual (36.8). when running M114 the printer thinks its at z 50 and so does Host. Does this suggest EEPROM settings?
  • Tried just in case. I set the Max Z to 240 - previously it was set to 0 meaning no max. The exact same behaviour is happening 
  • Here did you set to 240? Guess firmware since host has not 0 = unlimited.
    What happens if you send
    G1 Z25
    G1 Z50
    G1 Z75

    does it move 3 times same distance? Does M114 increase by 25 every time?
    Also check M119 when it stops moving. Maybe you are triggering an endstop so it stops, also I think it ha sno z max endstop.

  • Yes set that in the firmware of the printer.
    Doing as followed, the M114 changed by 25 each time, the actual printer moved by 25, then around 10, then nothing on the last command.
    Checked M119 at each stage and no change - all set to low
  • So this is definitively a printer issue, but can't say what. That printer also tells you it is at the position shows that it is not z max. But they do not use our firmware on A8 so I can not say more about that bug.

    How is it with the display of the A8 - can yo go higher there?
Sign In or Register to comment.