"Connection Lost" when I try to upload files

Everything seems to be running properly with regards to controlling my printer through the server.  I can move all axis, heat the bed and extruders, control the fan speed, and extrude.  I have a Solidoodle Apprentice, running the server on my Raspberry Pi B+, and running server version 0.51.1.

When I try to upload a file to the server, it gives me a "connection lost" error.  I have tried it wired and wirelessly, and have tried ascii, binary, all combinations of files that I can think of to create the g-code file.  Is there a secret to uploading the file that I am not seeing?  I am anxious to see if I can get this server to print.  Thanks.



  • I am creating my 3d files in Rhinoceros.  They have printed on the printer via USB.  I have been creating the g-code file with Repetier Host that I downloaded from Solidoodle and is set up for my printer.  I just tried to create the gcode file directly through Slic3r and I still received the same error. 

    For these files, I have been using my wifi connection, but I had tried a wired connection in the past.

  • I just tried it again with a wired connection, and it still lost connection on upload.
  • The webend shows the connection lost if it does not get a ping signal after x seconds. If you have a long upload that might trigger it while uploading. This will normally not effect the upload itself which continues and after it is finished the frontend will reconnect. Haven't seen this happen for a while now (also my development version has increased timeouts). So with next release it might also disappear for you.

    Anyhow, if you see the gcode file appear once uploading is finished, everything is ok.
Sign In or Register to comment.