Cannot write new settings to EEPROM from Repetier Host 1.0.6

Running a Rev. D Printrboard, and Repetier Host V. 1.0.6
Using the M501 command shows me the board has Z axis stepped to 2560 steps/mm
I write M92 Z506 for my settings, and the Z axis immediately moves according to the new value, and is correct, then I write M500 which used to save the settings to my EEPROM on the board. Write M501 again, and the old settings are there, 2560/mm Z.
Go into the Marlin Firmware EEPROM settings tab, and open it, change the 2560 steps value under Z to 506, and hit the "save to EEPROM" button, and it opens Ardruino to a blank screen and does nothing. 

This used to be a simple process right from Repetier. Why did this change? And why doesn't it work now. 
Can't set my Z axis properly without this function working or any of the other axis for that matter. 


  • 1. We havent changed that method for years, but marlin might have changed.
    2. What does "d it opens Ardruino to a blank screen and does nothing. " mean?
    3. In log you can enable command viewing. That way you see which commands get send. Does it send the right one or which is wrong.
    4. Whcih Marlin version are you using. There are so many sub-flavours and version that we can not test all.
  • edited April 2015
    2. When I click the "save to EEPROM" button, Repetier host minimizes, and the Arduino UI application you use for editing and loading firmware, launches, and sits on my screen open, with nothing loaded in the window. Not sure why that Application launches at all.

    3. I have the log/command viewing enabled, that's how I see the loaded steps/mm when I use M501, but the M500 command has never shown an indication in that log. The older Repetier I had, I would use m92 to change my steps, use m500, and the log wouldn't change, but then I'd run m501 again and the new steps/mm would be reflected in the log under "steps/mm", indicating the m500 command had worked. Now, it doesn't seem to be saving. The m92 changes are only temporary until i run m501 again and the old setting re-assert themselves.

    4. I will double check my Marlin version tonight. This is a brand new Printrboard Revision D from the guys at Makerfarm.

    Thanks for the response, I will check my options and get back to you!
  • I double checked, and my Printrboard Revision D. comes with Marlin RC2 firmware as listed by the manufacturer.

    Not sure if that answers the firmware quesiton, hopefully it does.  
  • I have checked it and it does what it should. I get exactly the same result as you because I have compiled Marlin without eeprom support. So as soon as you send M501 all changes are gone and saving does not save because firmware ignores it. So you should compile it with eeprom enabled.

    Not sure why it minimizes for you and starts Arduino IDE. For me it does nothing of both. Try rebooting windows and see if it is gone. SOmetimes strange things happen and vanish after a reboot.
  • I will try rebooting windows.

    I didn't actually compile anything for this board. It came with Marlin already on it, and I simply plugged it in and started trying to configure the steps/mm.

    So to edit and overwrite EEPROM settings, I will have to recompile either Marlin, or Repetier firmware with EEPROM support enabled and then start again?


  • If I do not wish to recompile my firmware, and everything else works the way it should, would I be able to do the following instead?

    1. Use M92 commands to find my exact step values for accurate movement without saving them to the EEPROM.

    2. Write those M92 commands into the custom Gcode window to run at print start.

    That way, when a print starts, the M92 commands should temporarily override the settings in the EEPROM.

    Makes sense as I can M92 the changes manually, and as long as I don't send M501, they stay and the movements are correct.


  • I'm not that familar with marlin, but yes you can change them temporarily with commands. You could write these commands in your slicers start gcode so they are definitvely set while doing a real print. And you can put them into a host script.
  • I tried rebooting windows, and it didn't help the random opening of the Arduino IDE.

    I will just keep the override settings in the slier start gcode, and use the machine as is.

    If I ever get more experience with compiling to the point of confidence, I will try re-compiling the firmware to my board with EEPROM support enabled.

    Perhaps with my second printer. Thanks for all the great help and fast responses. This is why I use Repetier.



Sign In or Register to comment.