Editing G-code script for manual control buttons.

edited July 2015 in Repetier-Host

When I  updated to version 1.5.4 the pull down box to allow editing of the  5 scripts for the buttons on the manual control screen seems to have disappeared from the G-Code editor screen. Is it located in a different place now?


  • same problem,  no one has posted a reply to CalData?   
    After upgrading the script drop down box is not there,  no way to edit scripts.   
    Previously i had scripts for buttons 1-4    for my Delta printer, i would send head to 3 areas around the round bed and with buttons 1-3   button 4 would send head to center,   all at Z=0 to test for bed level so i can manually adjust.   
    after upgrading buttons 1 and 4 do nothing,  2 and 3 send the head to the xy correctly, but not to z=0,  and none of them home before moving head.   So, i need to reprogram the scripts,  and see no way of doing so.  
  • OK,  I finally found another post that told to go to Printer Settings  / Script tab...   

    And, I sort of see why only some buttons/commands now work.  

    I don't know if this is considered a FIX or more proper,  or whatever,  or if it is a Bug in the 1.5x update, but previously the command line  and the scripts would accept <lowercase> and <UPPERCASE> commands.   
    like to home the head is G28
    Previously    g28 worked fine.    now it doesn't.   
    Not just 1 command,  all commands i've tested

    I noticed this when i tried to run manual commands,   lower case commands no longer work,   same in the script file. 
  • Scripts are now inprinter settings. Right clicking on button goes directly into the editor.

    If you are using the server connector the server parses gcodes and there was a bug until 0.60.3 not seeing lowercase commands. Will check if host connector has the same problem now.
  • Did you get a fix?
    I have no scripts in my script box and stuggling.

    Best ive got it so far.
    Some times I press 0.1 left on X and Y starts turning.
    E only turns threw lcd position.
    They thump when I press home and do nothing, some times if I home X it makes Y move. Been having Y and E spinning like mad just giving them a little movement but cant get X going. got Z doing it too.
  • If you say move x and y moves your motors are connected wrong.

    But could you please stop hijacking unrelated threads, that becomes annoying. I already told you how to progress.
Sign In or Register to comment.