V91 Tronxy x1, github, pots. Help driving me mad.

Hi all.
Gona try keep it quick.

Ive resorted to my pots and pulled volts down to 0.3 and still no matter what steps per mm I put in it wont move smoothly with manual control. I done 0.3 0.4 0.7 and 0.8v and no go best so far is struggling to home

Owned it months now and its annoying.

Used the github settings, used original settings and copied a million other eemproms but the manual control just dont work properly or it struggles towards the end stop with about 500 steps per mm on all motors.

My extruder motor goes stupid hot now at 0.3v and others dont and it still dont move. Thats another one too, whats the settings to stop it getting hot like that and make it work as my slicers set up. I just want to move it manualy or better still it just work the way it is suppose to.

Im suppose to feel resistance when motors on right? as Im sure Ive got this closer doing it by feel then with the volts. Dont think that all matching volts work.

Googled my motors and cant find them.
Code for them is
Tronxy motors
42h3454-23 for XY and z
42h3454-16 for the extruder.

Ive tried to print with it from sd and repetier host but refuses to move at all.

What should my printer setting, travel acceleration and Z steps per mm?

Tbh in seeing same question asked and never any proper answers always fw blabla.

What volts should my pots be at and what steps per mm for max 200mm with 16 tooth and Z axis 200mm because the reprap, prusa and the rest are obviously lying to me.

I run different steps per mm while tuning too.
Theres some videos on youtube

But the calculators dont give no 500 steps per mm no matter what settings I put into them so hows it taking this much and still wont move smooth or with manual control.

Tried a million ways annoying me now.
Im having to use bluetooth to my laptop too which is making updates or anything a nightmare.

Any help appreciated.

Or better still give me a name of another programme that works please as I been asking solidly daily for months and no one can answer.

Pcb is the melzi 2.0 v5 if you got 5min spare please.


  • All videos.
    Im wait for reply here as Ive exhausted everything else.
  • Using repetier v1.6.2 but v91 installed on printer.

    Im so close aha.
    400 steps per mm
    40mms feedrate
    30mm s homing feedrate "in video its at 31 and needs 31 to get any movement."
    10 jerk, playing with these now.
    3000ms2 acceleration

    All for X and Y
    Z is not moving or is the extruder.

    extruders at
    400 steps per mm
    100mms max feedrate "using bownden."
    15 mms start feedrate
    2000 mms2 acceleration.

    Tried a bunch of accelerations and these only ones that let it well try to let x and y home.

    You think I should just use github eeprom, throw a long gcode in and tune my pots?
  • Installed repetier 2.0.1? latest one.
    Same problems as videos.

    Is there a reliable setting I can tune my pots to on a dry run or with manual control?

    Is there a print in dry mode option? amd can I tune pots like that?
  • I installed 2.0 same probs. Will google. Can get them to crawl to end stop when homing when cant get manual control working 1mm 10mm ect. I turned pot down on extruder to stop the heat.
  • When I see the table shaking I just think the motor wires are not connected correctly. Either only one coil gets power then it just jitters or the 2 pairs are connected wrong and something unexpected will happen. Maybe you start with unmounted motors just to see if motors turn smoothly. Put some tape on the axis so you can better see it turning. But then you know you have forces and it should be a smooth movement depending on substeps. With 16 substeps it is 200*16 = 3200 steps per turn, so if you see any shakes on a slow move wiring is wrong.

    I assume of course that moving while motors off is easy. When motors are on it is normally very hard to move by hand.
  • I think last bit cover me bro, Im check them steps as I was at 400 with it shaking. Started with single digits
    That wasnt the numbers the calculator gave thats for sure. Max I got was 200. and 2560 for Z. I will do X and Y now.

    Shall I up the voltage untill I feel resistance and then try? as they are not locked when powered up.
    Thanks for tip with tape im do that.

    400 steps per mm 0.685v per pot no heat except the extruder. I think pots may have different voltages to work and not all be the same aswell as steps per mm way off

    I will come back and do a proper video. Forgive me for being messy, I have anxiety issues.

    Very gateful for your time as Im pretty sure it is one of these to as you say we got forces/movement so we have communication ;) nearly there. Im guessing my pots come loose or wasnt set from manufacturer aswell as worng steps per mm.

    I will be back and give results to this for future refference. 

    Thanks for your time.
  • Did it ever work with stock firmware?
    There is a point on the trim pot where the stepper motor will move smoothly and then if you go on either side of that point it gets jerky and/or stops altogether. I don't have that printer but I have found that to be true. I would start at .5 - .6 V. I would also disconnect the belt and try it with no load to see if it will go at all. I currently have a core-xy (home built) and my accelerations are lower than yours (1500). Good connections are crucial.
    Also with my setup (20 tooth pulley, GT2 belt) I'm at 80 steps/mm for X and Y axis.(I have a RAMPS)
    I was looking around the web and I've seen posts where the steps/mm were around 100 for the Tronxy.
    Also I have found that if your firmware does not know the position it is at on powerup, (homed - either using limit switches or g-command) it will only move in a positive direction, so if the hardware is physically at the positive limit you cannot move below zero,(the coordinates will be in red if unknown.)
  • No not worked from the start. 

    Ive had the pots max 0.780v and messing with steps per mm the motors will turn some times right down to 0.2v depending on steps per mm and accelerations.

    Yea im 16 tooth calculations been 88.889 x and y 2560 on z. But guy above says 3200 I dont see how should I even try it? 

    The original accelerators were 400. Ive built up to 3000 to get them to move like this video

    but thats 400 steps per mm x and y and its aiming towards the end stop. I built the steps up in 20 increments too.

    I did have them turning a little when using manual control but 10mm command jumped 1mm and like stooled.

    I just want to be 100% on steps per mm and accelerations and il print a file and just turn the pots till they work. If it blows it blows im mad woth it and got a few ranps and a pile of 4988 drivers anyway but I needed this to work to build my other printers, i got a A8 too but want to learn on this as im new.

    I mean guy above you says do 3200 steps per mm but how can that be if ive done the calculator for 88.889 steps ? he says sub steps. Shall i try these as tbh Ive been keeping the numbers low to not cause problems. What about the printer setting, printer size tab theres acceleration and feedrate, what should these be as Ive had movement adjusting them too.

    Yea the github settings is 100mm calculator says 88.889 and 2560 Z. No idea what E should be but its at 90 and ive played woth no joy for says now.

    Tbh 0.8v Motors got hard to turn and E was cool but dropped down to 0.2v to 0.4v and got some same movements but extruder motor got hot. Had it pulsing too at 0.5v

    Yea I done that and put belts on as Id got them moving with manual control before but not perfect so i hooked belts up thinking I was done with this crap. Z and E are loose.

    Right now im 0.6v and can feel clicking extruder and it feels like its clicking right by the feel but it wont turn off or move manualy. Emergency stop to stop it.can feel it turning notching but not actually turning. Had it pulsing to last night but got hot fast, that was 0.3v.
    Its been at 90steps per mm. Ive tried few others with no joy.

    The x and y are at 400 steps per mm and 3000 acceleration with 30 feedrate in the video but thats only homing they refuse to move manualy. if I drop to 1000 they dont move. I built up from 400 to 3000 to get them to move with 400 steps per mm x and y and 31 feed and jerk 3000 accel.
    Tried above with calculated steps and no go.

    I had the jurk moving them at 30 to 35 ish  but all settings ive seen jerk says 15 or 20,X and Y. I had them move at 8 cant remember pot volt or steps per mm. I tried so many random ones.

    I have had it move Y when ive pressed home X and then when moving X left 1mm it attenpted to move Y down. pots were about 0.5v then.

    I tried inverting but gave up.

    In repetier host, printer size is it? theres a feedrate per minute and acceleration per minute.

    Sorry for long messages, just trying to explain best I can.
    I got it set up now and willing to try what ever.

    Very grateful for replies. Been on all groups, even tronxy x1 fb group and people wont even tell me the settings, fkn mad mate. I quit this 3month ago and come back to it because people just get me mad.

    Im just having a coffee and im record best I can my feed and settings ect. Got all them vids on youtube and not 1 answer its bs.

  • What I said is a motor with 200 steps per rotation and 16 substeps for driver set needs 3200 steps per rotation. For xy you have to take into account how much mm that moves a belt. E.g. 10 teeth with 2mm distance = 20mm circumspehere so 3200/20 = 160 steps per mm. That was for the idea that you make pulley loose to just see how motor moves without force. Here jerk has less meaning. But you set it to 20 and steps per mm to 100 for testing.

    Also make sure to change them in eeprom so you really have the values you think.
  • edited July 2017

    Right now.
    I followed this guide.


    I got the original settings but right now I used the reset command. Even tho its for ponterface I done it with repetier host.
    I am at the commands just after the reset command.
    It wouldnt connect after, I had to change baudrate down to 11500 ish, my lcd always showed 250000 and on video it is but not it working under 115000 baudrate after the reset command.

    I used the Z command and it turned, I press end stop and it goes super fast and dont stop lol, not even if I emergency stop. I have to pull the power.
    X and Y ,X dont move and Y thumps.
    Im at the "turn off extruder heat command" and command to move extruder which has made the extruder motor do same thing as Z did.
    Repetier is not controling them.

    My driver pots are at 0.001v and thats obv wrong not sure what I should do now.

    Please advise.
    I will read your comment now.
    Thanks for your time.
  • Bro.
    Im newb your going to have to tell me like nursery child

    Im trying to show best I can threw video and asking every were but not getting dorect answers.

    Im at what ive done above. The orinter obviously came woth them settings new and the pot volts were 0.7400 ish but some were low.

    Shall I just run a print and turn my pots?

    How do I activate eeprom?
    Its like the commands are not getting threw with the manual control at all.

    The melzi has 0.91 or 0.92 and I read a ton of people with same problem. "youl see i the video as I reset it a few times."

    Does certain versions of repetier host only work with certain repetier that are flashed?
  • edited July 2017
    Here is a github link to a guy that setup for a Tronxy with a Melzi board.
    If you look at his configuration.h, you will see what he setup for his machine. You can plug them into the configuration tool on the website.
    Did you build this from a kit? what does the code M115 return? (you enter it in the g-code window in RH)

    If you burn the firmware I always run the eeprom_clear sketch first to clear the board before burning firmware.
    also check the line define EEPROM_MODE #. anything between 1-255 enables EEPROM. If it is above 0 you could change it to a different number so it will overwrite the old values.

    The burn is done using Arduino software. For specifics google it.

    Hopefully a power down/power up would restore your voltages.I hope nothing blew. I'd set them to about .5-.6V to start. The main thing is to get stuff working then tweak.

    I stayed with Ver 1.6.2, I liked the contrast/colors better and it works fine for me.
    Good luck!
  • Hi
    M115 gives 100 feedrate.
    Yes I bought a couple of kits and Im asolutely new but I have done a few months researching.
    I already grabbed that github and tried to copy it. I copied all the eeprom ect but not got to flashing yet as I wouldve thought it should of worked out of the box.

    Ive been and grabbed the configh and jason but im not understanding Arduino ide and wasnt expecting to use it yet, I wanted this printer to print parts while I learned. I got quite a few builds on and totaly newb.

    But you when I use ide it dont have my board type and when it has, I deleted it all todays and started over, got it open on my screen now and it only sayingsketch jul 1.0.5 I followed greetechs guide today but no joy so il jave to re do it all.

    But anyway
    Iwas playing and used auto format, had looks threw and tried to verify and compile but it says I need to change some things and I have no idea how. Im not even sure what bits im having to use either.

    Worst thing is I only got internet on phone so im having to bluetooth files like that but I did have all these files in ide as another guy sent me some marlin set up and few other things.

    I goto learn but I expected this printer to work, it has

    What Im noticing now is if I home X then Y then Z they may juder a mm or 2 then I can feel extruder trying to go but the driver to the extruders getting super hot. Only way I can control it is to go threw lcd to position and move extruder 1mm which will make it turn and just keep going, nothing in repetier host or the end stop wll stop it but turning the position to -1 will make it stop and switch.

    Ive had X and Y doing similar from pressing home but right now with all original setting the just jult a few mm. Z accasionely screams and moves a little.
    I had X just oressed right on manual control and it started spinning like mad, end stop wouldnt stop it. Had Z and Y do this to not even emergency stop stops them, Its quite dangerous really imagine if I had it hooked up to bed and belts, motors wpuld be burned up and things broke.

    My volts are at 0.001 on driver pots when power with only the usb jumper. Ive been upto 0.750 today and even attempted to adjust while set to print and nothing, I never went over what I know is 0.800 kind of position.

    Maybe I need 1v?

    Tbh once ive moved the exttuder 1mm threw lcd position the driver cools but man im suprised it aint burned out.

    Im out of ideas now and if no proper answer in just throw it to the side. Ive researched and asked and asked and asked and asked for months.
  • People who made the host cant even give a direct answer.
    Ive even done videos up there and can see my setting and feed log

    Last one I done before I tried to do greetechs set up today which failed.
    I wont be doing any more as any one who knows what they talking about should be able to see from the video but still people cant give direct answers.
  • Im sort anet out and il check back im fed up of this 1 I got a bunch of vseries, nema 23s 17s and 14s but cant even get this piece of crap to work so maybe im in wring hobby or something cuz every one talk like they know what they talking about, you buy and do what they say and it turns out bs
  • rixstaa said:
    Im sort anet out and il check back im fed up of this 1 I got a bunch of vseries, nema 23s 17s and 14s but cant even get this piece of crap to work so maybe im in wring hobby or something cuz every one talk like they know what they talking about, you buy and do what they say and it turns out bs
    I can't help but respond to this post, given I am a tronXY X1 owner - apologies if I'm resurrecting it, but I feel it's important for anyone else that might have this issue.
    Firstly, TronXY made this printer, not Repetier, blaming them and their attempts at helping you is just, insulting, I understand how stressful these issues can be to a beginner, but it doesn't help.

    Secondly, This model uses roughly 100 steps/mm, 400 is to put it bluntly - insane and would never work. Using such high settings may have burnt out the voltage regulators, and if not could permanently damage the motors.
    From what settings I can see in your firmware, everything is wrong - which means you changed everything to something wrong - I'm guessing you attempted to install a custom firmware or alike?

    thirdly, tuning down the pots will prevent the motors from moving at all, Like most TronXY parts they are cheap and low quality, they require more voltage to move, not less.
    The factory calibrations are almost always correct and I have never needed to replace the pre-loaded firmware.

    Finally, Video is generally very unhelpful, especially shaky video that doesn't show much of the printer itself.

    I apologies if I sound dismissive, it's not my intention - I'm just shocked at how the printer ended up in this state, I'm going to guess bad advice by people who own different models.

    If by some miracle you haven't thrown the entire thing in the bin my now, I'm attaching a screenshot of my firmware settings, please note these are modified by only the smallest amount for calibration purposes; thus should help you and any other users.

    For all TronXY users, The TronXY manual explaining how to build and setup the printer was included on the SD card - I do not suggest deviating from it at all if possible, it is cheap and chineese and has very little tolerance for errors on the part of the user..
Sign In or Register to comment.