No longer able to view / change Firmware EEPROM Configuration on my Printrbot

I've been using Repetier-Host with my Printrbots for a long time.  First an LCV1 (from the original Kickstarter) and now with my Metal Plus.  In the past, I was able to view and edit EEPROM parameters like steps/mm in the Firmware EEPROM Configuration dialog.  I haven't had a need for that in a long time, and when I tried it today, I found that option is greyed out (can't be selected).  I think this may be because I updated the firmware on my machine and they have changed the ID string.  I have read that feature only works with Repetier-Firmware, but it definitely did used to work on my Printrbot and it's a very useful tool.  Is there some way I can get this feature back?


  • It also support Marlin, but it only enables feature if it detected a known firmware and this is decided on the M115 string we get. So if someone changes the string to a new unknown firmware it gets disabled.
  • As I suspected, thanks for confirming.  May I ask that Printrbot's latest firmware be added to the known firmware list.  M115 on my metal plus returns

    FIRMWARE_NAME:PB Marlin Rev F v5 FIRMWARE_URL: PROTOCOL_VERSION:1.0 MACHINE_TYPE:Printrbot EXTRUDER_COUNT:3 UUID:00000000-0000-0000-0000-000000000000

  • Done. It was searching for "marlin" and now I've added "Marlin" as well. SO 1.6.2 will detect it again.
  • Outstanding.  Thanks so much.  Any idea when 1.6.2 will be released?
  • Not really. We want it to handle some new server features and the server release is still in progress. Maybe june.
  • Hi - I was wondering what the current state of this issue is :) I have an Anet A8 Prusa i3 clone which seems to be using Repetier firmware. Normally I am a Mac user and Repetier Host Mac 1.0.2 plays very nicely with the EEPROM via the 'Firmware EEPROM Settings' window. I have tried with two Windows versions ( 1.6.2 and 1.0.5 ) however and Firmware EEPROM configuration is greyed out. 

    M115 returns - FIRMWARE_NAME:ANET_A8_20160525

    So really I guess I am curious as to why it works ok on Mac ?

    I am aware of Anet not releasing the source and have vocalised about this.
  • Reason is windows host tests for firmware type since it also supports marlin eeprom. Soif it sees repetier in firmware string it enables it. Since A8 has changed firmware name that fails. Mac seems not to test type:-)

    With repetier-Server it would also work since you say there whcih firmware you use so it does not need a autodetect.
  • Thanks - seems like it would be a good idea to have Windows behaving the same as the Mac version as it is a very useful feature. I know the string check is simple coding but a more open approach would be far more versatile - dump eeprom contents regardless :)
  • Unfortunately different firmwares use different solutions for eeprom. That is why we need firmware detection. Will think if there is a other method detecting the firmware also M115 fir,ware name was what it was meant for.
  • Greetings,

    I seem to have this same problem on my Dell running Ubuntu 16.04 LTS with Repetier. The "Firmware EEPROM configuration" is greyed out. I have a Troxy 3D printer with a Melzi board running a Marlin firmware V1.0. At first, the Linux machine detected the 3D printer with no problem, but after a few days I can't seem to get it to connect to the PC.
    I have tried every to change every "variable braudrate" in the printer configuration option and still - can't get this thing connected.

    However, when I try connecting my Surface tablet running Repetier - it connects like a charm. Does, anyone have some steps that they can share - so I can fix this issue?

    Kindest regards,
  • Host detects firmware with M115 and if it contains marlin or repetier it activates the eeprom. So send it manually and see in log if it contains either of these strings.
  • n00b here... Having the same issue:  Firmware Configuration is blank. It took me a decent while just to connect my printer to Repetier. My background isn't really in computer science, so you have to use small words. 

    M115 returns - FIRMWARE_NAME:ANET_A8_20160525

    Please help!  I need to calibrate this printer to do anything useful, and this has been a huge headache.  Thanks!
Sign In or Register to comment.