Mac - 'Set Home' Z axis can't be negative figure

I've just upgraded the firmware on my Davinci 1.0 to Repetier and it is fantastic, one issue is that the only way to alter any axis into a negative figure is through a Windows PC in the Eeprom Settings as the Mac 'Set Home' only seems to allow it to be zero and above unless it has been pre-set to a negative figure on a PC. Any way around this?? Thanks.


  • The controls should not allow negative coordinates, that is below print plate and should be prevented. If you really need it just send the gcode, e.g.

    G1 Z-1 F100

  • Thanks for the reply, I in fact found that it can be done but sometimes needs to be disconnected & reconnected in order to get those particular settings to show so that you can edit them. Please see my other question though in regard to slicing. Thanks.
  • For the record, the problem is that skeinforge can't locate the files each time because the new mac OS system has a hidden library so when it tries to find the sliced g-code to load it comes up with an error and you have to manually located the g-code through 'finder, library, repetier' (a pain to do each time)... and it would be nice to have an alternative to slic3r... I wish Cura was built in to the Mac Repetier software! Is this on the cards?
  • Skeinforge has diffenerent options which change the generated file name and that can confuse the host. You need to select export in filename generation and no dates etc. So it is oldfile_export.gcode whcih skeinforge creates.

    CuraEngine is planned, but we currently have not much time left for the mac host. We will try to run the windows host with mono on mac soon and see if it is still a nightmare or if it is good enough to make that available on mac. Then you would have a CuraEngine support.
Sign In or Register to comment.