Worked for a while, now crashes when I try to connect to my printer

I'm running Repetier-Host Mac with my Delta printer using Marlin firmware on a Ramps 1.4 board. Everything has worked fine until last week. Now when I try to connect to my printer, Repetier crashes. Thinking that there's a corrupt file somewhere, I've tried to uninstall and delete all the settings from Library/Preferences and Library/Repetier, but there seems to still be preferences stored somewhere, because when I open Repetier-Host, my printer settings are still stored. Nothing on my printer firmware has changed between when to worked and when it stopped working.

Any ideas?


  • There is only one preferences file


    so deleting it should help getting it running again. Except this there are only the slic3r profiles which are read on startup, but here only file names matter not content.
  • Here's the error in the system log:
    12/8/14 11:09:18.750 PM Repetier-Host Mac[50346]: *** -[__NSArrayM objectAtIndex:]: index 4294967295 beyond bounds [0 .. 1]

    12/8/14 11:09:18.753 PM Repetier-Host Mac[50346]: (
    0 CoreFoundation 0x95d20343 __raiseError + 195
    1 libobjc.A.dylib 0x93cc7a2a objc_exception_throw + 276
    2 CoreFoundation 0x95bd5714 -[__NSArrayM objectAtIndex:] + 244
    3 Repetier-Host Mac 0x00022caa Repetier-Host Mac + 138410
    4 Repetier-Host Mac 0x000231f6 Repetier-Host Mac + 139766
    5 AppKit 0x9226cd57 -[NSView _drawRect:clip:] + 4221
    6 AppKit 0x9226b582 -[NSView _recursiveDisplayAllDirtyWithLockFocus:visRect:] + 2071
    7 AppKit 0x9226953a -[NSView _recursiveDisplayRectIfNeededIgnoringOpacity:isVisibleRect:rectIsVisibleRectForView:topView:] + 876
    8 AppKit 0x9226a7f4 -[NSView _recursiveDisplayRectIfNeededIgnoringOpacity:isVisibleRect:rectIsVisibleRectForView:topView:] + 5670
    9 AppKit 0x9226a7f4 -[NSView _recursiveDisplayRectIfNeededIgnoringOpacity:isVisibleRect:rectIsVisibleRectForView:topView:] + 5670
    10 AppKit 0x9226a7f4 -[NSView _recursiveDisplayRectIfNeededIgnoringOpacity:isVisibleRect:rectIsVisibleRectForView:topView:] + 5670
    11 AppKit 0x9226a7f4 -[NSView _recursiveDisplayRectIfNeededIgnoringOpacity:isVisibleRect:rectIsVisibleRectForView:topView:] + 5670
    12 AppKit 0x9226a7f4 -[NSView _recursiveDisplayRectIfNeededIgnoringOpacity:isVisibleRect:rectIsVisibleRectForView:topView:] + 5670
    13 AppKit 0x9226a7f4 -[NSView _recursiveDisplayRectIfNeededIgnoringOpacity:isVisibleRect:rectIsVisibleRectForView:topView:] + 5670
    14 AppKit 0x92268d14 -[NSThemeFrame _recursiveDisplayRectIfNeededIgnoringOpacity:isVisibleRect:rectIsVisibleRectForView:topView:] + 311
    15 AppKit 0x92265a78 -[NSView _displayRectIgnoringOpacity:isVisibleRect:rectIsVisibleRectForView:] + 2942
    16 AppKit 0x92242f51 -[NSView displayIfNeeded] + 1629
    17 AppKit 0x9226175c -[NSWindow displayIfNeeded] + 324
    18 AppKit 0x922a0570 _handleWindowNeedsDisplayOrLayoutOrUpdateConstraints + 1262
    19 AppKit 0x9290b65b __83-[NSWindow _postWindowNeedsDisplayOrLayoutOrUpdateConstraintsUnlessPostingDisabled]_block_invoke1560 + 58
  • 20 CoreFoundation 0x95c2ca2d _runLoopObserverWithBlockContext + 29
    22 CoreFoundation 0x95c2c350 __CFRunLoopDoObservers + 400
    23 CoreFoundation 0x95c1dcb2 __CFRunLoopRun + 946
    24 CoreFoundation 0x95c1d696 CFRunLoopRunSpecific + 390
    25 CoreFoundation 0x95c1d4fb CFRunLoopRunInMode + 123
    26 HIToolbox 0x9660e178 RunCurrentEventLoopInMode + 262
    27 HIToolbox 0x9660deb1 ReceiveNextEventCommon + 494
    28 HIToolbox 0x9660dcac _BlockUntilNextEventMatchingListInModeWithFilter + 99
    29 AppKit 0x92130d99 _DPSNextEvent + 734
    30 AppKit 0x921305e1 -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 186
    31 AppKit 0x92122dac -[NSApplication run] + 907
    32 AppKit 0x9210c310 NSApplicationMain + 2082
    33 Repetier-Host Mac 0x000022a5 Repetier-Host Mac + 4773

    12/8/14 11:09:27.524 PM Repetier-Host Mac[50346]: *** -[NSLock lock]: deadlock ( '(null)')

    12/8/14 11:09:27.524 PM Repetier-Host Mac[50346]: *** Break on _NSLockError() to debug.
  • After deleting /Users/yourlogin/Library/Preferences/repetier.Repetier-Host-Mac.plist, the settings under Printer> Printer Settings are still set how I initially set them. I would expect them to have been deleted if the only settings were in the plist file. Repetier still crashes when I attempt to connect.

    The above log dump is in two parts due to post length restrictions.
  • I am also having issues with Repetier no longer working.
    The overall program seems corrupted. I can click on Printer preferences and it seems to work but if I try and connect to my printer the spinning beachball appears and nothing else happens.
    I deleted the plist file but it still seems to remember the printer settings.

  • On newer Mac versions deleting the plist is not a solution as OS X will restore old content from cache, Use instead

    defaults delete repetier.Repetier-Host-Mac
    to start with fresh settings.
  • On newer Mac versions deleting the plist is not a solution as OS X will restore old content from cache, Use instead

    defaults delete repetier.Repetier-Host-Mac
    to start with fresh settings.
    Had the same issue, pasting this into terminal did the trick :)
  • im having the same problem with every version of repetier, slicer, and cura! they all crash if i load a print or if i connect to the printer. sometimes it crashes on start up. worked fine for 3 days. the copy and paste doesent work says domain not found. what should i do? also... cura will run for a few hundred lines then stop for about 45 seconds then it continues why does it do that?
  • @skippyq96
    You are talking about windows or linux version? Mac has no curaengine.
  • I had the same problem, I solve it choosing manually the port were my printer was connected.
Sign In or Register to comment.