repetier-host mac 0.56 non-responsive

I had a slic3r job that froze, so i did a force quit, did a repair via netfabb online services. Tried again and it froze again in the slic3r process, so I did a force quit.  Now when i open repetier sort of works, except I can not add an stl, by clicking add stl.  I cannot select the slic3r tab / slic3r settings.  If i open directly a .stl file it will show up in the display area, but not on the right side.   After a bit the file will just disappear.  I have deleted the application and /Users/yourlogin/Library/Preferences/repetier plist and slic3r files.  downloaded a fresh copy an no go. any ideas..


  • Hello,

    I got the same problem. Repetier Host start, but one second later it crashes. I deleted it and deleted also
    /Users/yourlogin/Library/Preferences/repetier plist and slic3r files. BUT i serched in my "Macintosh HD" for other files named "Repetier" and deleted also this files (I don't know if you do). Then delete all files in trash can, restart osx, reinstall with a fresh copy and now it works.
  • Same problem here. I thought I fried my printer but I was able to hook it up to another computer and everything is OK with the printer. Tried deleting it from the application folder and reinstalling but that didn't help.
    I'll try the above steps to see if that fixes it.


  • On newer Mac versions deleting the plist is not a solution as OS X will restore old content from cache, Use instead

    defaults delete repetier.Repetier-Host-Mac
    to start with fresh settings.
  • Thanks for your response.

    I did this command from Terminal and got:

    Domain (repetier.Repetier-Host-Mac) not found.
    Defaults have not been changed.

    I'll try an install now and see if it still occurs.


Sign In or Register to comment.