Fail to fill buffer

I encountered a problem with Repetier Server on a raspberry pi with a cartesian printer. The move buffer size is 16 and input buffer size is 127.
After 25 or 30 layers the movements occurs only once or twice per second. The LCD shows Buf:0 and I get this log from console tab :


  • In addition, this error occurs after deactivating and reactivating the printer.
    Since the PI was restarted there's no print problem.
  • I had this very seldom. In 0.51.1 I had changed some parts which hopefully avoid this. I didn't seen it since then, so which version was in use when it happened? Normally restarting the server helps.
  • edited March 2015
    I have 0.51.0, good news, I'll update server. Thanks.
  • I am also struggling with this issue.

    I am running 0.51.1 on a fully updated pi b+

    if i reboot my pi i can usually print for an hour or more but if i leave the pi running for a day or so, any significant print will display this behavior. only one command per second or so.

    If I reboot, I can usually print the same job successfully.

    Any thoughts on what I might do to solve this problem?

  • Yes, the problem seems to come from communication errors where the buffer fill state does not get adjusted correctly. Our guess is that resonding "ok" get something like "o" or "k" not beeing detected. Incombination with repetier-firmware we have a solution that should repair corrupted ok backmessages automatically. Here we use the line number after the ok to free all lines before acknowledged line so it will catch the missed "ok" with the next command. That is possible because we buffer several commands. That is also why the problem takes so long to occur. At first buffer has a buffer.

    Not really sure how to solve this with Marlin, because marlin gives no backinfos on where ok belongs to. Maybe I should simply add a timout reset here as fallback for everything.
  • As a temporary solution disable and activate printer before a print. That resets buffer counting. Especially since your error rate is so low that it takes days it shoudl survive at least a print. Or find a baud rate with even less errors.
  • Hi, I'm having the exact same problem on my DaVinci 1.0A flashed with repetier 0.92, I'm trying to run it with a fully up to date raspberrry 3, but the buffer keeps dropping to zero every few seconds, as well as the temperatures keep showing zero ever few seconds, I've tried every baudrate, tried ping pong mode, reflashed my raspberry and my printer but no luck.
    What is weird is that on Repetier Host, every thing works fine and the buffer fills correctly, I also tried Octoprint on the raspberry and it works well with no buffer problems on multiple baudrates.
  • Have you selected repetier firmware in printer configuration? Also enable print logging and check the log - most problems get visible there and it is much easier to guess what is going on.
Sign In or Register to comment.