The button connect to printer does not work

Hello,

I have already checked othe discussions in the forum but no problem seems to be similar to myne

I am trying to connect my 3D printer My Creator 2 to the program Repetier-Host version 2.2.4
I am using an AppImage running only once, i.e. by the SW Repetier-Host-x86_64-2.2.4.AppImage.

The button "connect to printer" does not work, I have tried to change some com parameters, but no change.
The USB is connected to the printer by /dev/ttyUSB0, bit rate 250000 and so on.
All other commands of the GUI work well, only this button shows some problem
Do I have to install the AppImage SW definetely on PC or something else?
In the past I had no problem to connect the Repetier-Host to the printer, I used the version 2.0.5 but not the AppImage version...

many thanks in advance for some feddback
Federico

Comments

  • C# on linux has issues with non ansi baud rates. So to select 250000 we connect then call an external c++ software and that normally works. But maybe it has a problem on your linux, e.g. a library missing or  your linux is 32 bit. You can check it probably if you start it from terminal so you see error messages in the terminal what might give a hint.

    You can also try to switch printer to 115200 so it uses a ansi baud rate that c# can handle it self.

    Other solution which is also better is to install  Repetier-Server and connect printer over that. In host you then use  Repetier-Server Connector instead of serial connector to connect. The server also has no issues with 250000 baud and you can even close host while printing and printing still continues. 
  • Hello,

    thanks for the prompt reply.
    My linux is of course 64bits, furthermore I had no problem with an old version of Repetier-Host :-(
    I will check it and then I wil inform you if that works

    BR
    Federico
  • Hello again,

    first, I changed bit rate, e.g. 115200 or other but no improvement noted.
    Then, I tsarted the AppImage program from the terminal and attached the messages generated after running the program:

    ----------------------------------------------
    xxxx$ ./*.AppImage

    Warning: Ignoring XDG_SESSION_TYPE=wayland on Gnome. Use QT_QPA_PLATFORM=wayland to run on Wayland anyway.
    LD_LIBRARY_PATH = /tmp/.mount_RepetiI01vSs/usr/lib:
    MONO_PATH = /tmp/.mount_RepetiI01vSs/usr/lib
    Could not set X locale modifiers
    Gtk-Message: 11:13:12.576: Failed to load module "canberra-gtk-module"

    Opening serial failed on second try:System.IO.IOException: Keine Berechtigung
      at System.IO.Ports.SerialPortStream.ThrowIOException () [0x0000f] in <9c6e2cb7ddd8473fa420642ddcf7ce48>:0
      at System.IO.Ports.SerialPortStream..ctor (System.String portName, System.Int32 baudRate, System.Int32 dataBits, System.IO.Ports.Parity parity, System.IO.Ports.StopBits stopBits, System.Boolean dtrEnable, System.Boolean rtsEnable, System.IO.Ports.Handshake handshake, System.Int32 readTimeout, System.Int32 writeTimeout, System.Int32 readBufferSize, System.Int32 writeBufferSize) [0x0001b] in <9c6e2cb7ddd8473fa420642ddcf7ce48>:0
      at (wrapper remoting-invoke-with-check) System.IO.Ports.SerialPortStream..ctor(string,int,int,System.IO.Ports.Parity,System.IO.Ports.StopBits,bool,bool,System.IO.Ports.Handshake,int,int,int,int)
      at System.IO.Ports.SerialPort.Open () [0x0006f] in <9c6e2cb7ddd8473fa420642ddcf7ce48>:0
      at RepetierHost.model.ProtectedSerialPort.Open () [0x00035] in <63c553364181423faf81fbf20d6b440d>:0
      at (wrapper remoting-invoke-with-check) RepetierHost.model.ProtectedSerialPort.Open()
      at RepetierHost.connector.SerialConnector.Connect (System.Boolean failSilent) [0x00208] in <63c553364181423faf81fbf20d6b440d>:0

    Opening serial failed on second try:System.IO.IOException: Keine Berechtigung
      at System.IO.Ports.SerialPortStream.ThrowIOException () [0x0000f] in <9c6e2cb7ddd8473fa420642ddcf7ce48>:0
      at System.IO.Ports.SerialPortStream..ctor (System.String portName, System.Int32 baudRate, System.Int32 dataBits, System.IO.Ports.Parity parity, System.IO.Ports.StopBits stopBits, System.Boolean dtrEnable, System.Boolean rtsEnable, System.IO.Ports.Handshake handshake, System.Int32 readTimeout, System.Int32 writeTimeout, System.Int32 readBufferSize, System.Int32 writeBufferSize) [0x0001b] in <9c6e2cb7ddd8473fa420642ddcf7ce48>:0
      at (wrapper remoting-invoke-with-check) System.IO.Ports.SerialPortStream..ctor(string,int,int,System.IO.Ports.Parity,System.IO.Ports.StopBits,bool,bool,System.IO.Ports.Handshake,int,int,int,int)
      at System.IO.Ports.SerialPort.Open () [0x0006f] in <9c6e2cb7ddd8473fa420642ddcf7ce48>:0
      at RepetierHost.model.ProtectedSerialPort.Open () [0x00035] in <63c553364181423faf81fbf20d6b440d>:0
      at (wrapper remoting-invoke-with-check) RepetierHost.model.ProtectedSerialPort.Open()
      at RepetierHost.connector.SerialConnector.Connect (System.Boolean failSilent) [0x00208] in <63c553364181423faf81fbf20d6b440d>:0

    Opening serial failed on second try:System.IO.IOException: Keine Berechtigung
      at System.IO.Ports.SerialPortStream.ThrowIOException () [0x0000f] in <9c6e2cb7ddd8473fa420642ddcf7ce48>:0
      at System.IO.Ports.SerialPortStream..ctor (System.String portName, System.Int32 baudRate, System.Int32 dataBits, System.IO.Ports.Parity parity, System.IO.Ports.StopBits stopBits, System.Boolean dtrEnable, System.Boolean rtsEnable, System.IO.Ports.Handshake handshake, System.Int32 readTimeout, System.Int32 writeTimeout, System.Int32 readBufferSize, System.Int32 writeBufferSize) [0x0001b] in <9c6e2cb7ddd8473fa420642ddcf7ce48>:0
      at (wrapper remoting-invoke-with-check) System.IO.Ports.SerialPortStream..ctor(string,int,int,System.IO.Ports.Parity,System.IO.Ports.StopBits,bool,bool,System.IO.Ports.Handshake,int,int,int,int)
      at System.IO.Ports.SerialPort.Open () [0x0006f] in <9c6e2cb7ddd8473fa420642ddcf7ce48>:0
      at RepetierHost.model.ProtectedSerialPort.Open () [0x00035] in <63c553364181423faf81fbf20d6b440d>:0
      at (wrapper remoting-invoke-with-check) RepetierHost.model.ProtectedSerialPort.Open()
      at RepetierHost.connector.SerialConnector.Connect (System.Boolean failSilent) [0x00208] in <63c553364181423faf81fbf20d6b440d>:0

    ----------------------------------------------

    Can these messages help solve this matter?

    many thanks in advance for some feddback
    Federico

  • > Opening serial failed on second try:System.IO.IOException: Keine Berechtigung
    The serial ports belog to group dialout, but apperently the user running the host does not. So that is a simple issue as it seems. You need to add group "dialout" to your user. 
  • Hello,

    now it is works.
    By the command :~$ sudo adduser <user> dialout then with restart it was possible to connect finally the program Repetier-Host to the 3D printer

    Again many thanks for the support

    Br
    Federico

Sign In or Register to comment.