Package has no instalation candidate

Hi! I am trying to install klipper but I am getting this error in the wizard


I am quite new to linux and have spent a couple hours googling but could't find a solution

Help will be highly appreciated!

Regards!


Comments

  • Looks like you are not using a pi. Which distro and version are you using on which processor?

    Main problem is that klipper uses the older python2 that is being replaced by python3 so old package names start to not work as I see on some distros. But klipper likes python 2 as it seems to be faster. And they are unfortunately also not 100% compatible.

    Anyway, I have modified the install script to check if python2-dev exists and use that package name preferred. I hope this works on your distro now. If you get more issues with package names let me know together with the message like you did. I can then adjust ist to work on your distro as well.

    BTW: You can copy the output in the terminal window and paste it here. No need for an image.
  • edited August 15
    Hi! Thanks for the reply.

    I am using a Ubuntu 22.04.1 LTS and the processor is Intel Celeron J4005.

    That managed to solve it, but I have another poblem now.

    I was able to create the firmware following a guide (I have SKR mini e3 V2), flash my Ender 3 by renaming the file to firmware.bin, putting it in my sd card and inserting it in my sd port, but now my LED is blank (light's up but nothing is on the screen).

    Also, I tried using command "ls -l /dev/serial/by-id/*" but it says "no such file" and doesn't list the printer as connected, but it worked before.

    BTW, I used instructions from this post to sep up klipper for my config https://www.reddit.com/r/ender3/comments/dtl8re/skr_mini_e3_12_klipper_configguide_including/





  • > LED is blank
    Do you mean LCD? That needs to be configured in your klipper configuration file. When editing the file make sure klipper starts it without errors (see connecticon if there is a warning symbol). Also note that the 0.10 and latest are quite different in configuration as latest has made several config methods not working, especially analog/digital pin names and stepper configuration has changed a lot. So watch out what tutorials are using.

    What is more an issue is that you don't see the board - that means the firmware stub is not working or not offering a serial to outside. Make sure you have selected correct architecture in menuconfig for your board and also that the serial config settings are correct As long as no port appears the rest will not work anyway as the klipper server is responsible for lcd content.
  • edited August 15
    I managed to fix it but I am not sure how.

    I think I reflashed the firmware, restarted the printer and then changed a line in the config because [mcu] was pointing to another port and that did the trick.

    Thanks for the help :)


Sign In or Register to comment.