Compute Module 4 IO Ramps 1.4 Connection problem

edited August 11 in Repetier-Server
Friends, I was using my Ramps 1.4 card with RPI4 (with Arduino Clone) without any problems. I want to replace Raspberry Pi 4 and use it with the RPI Compute Module 4 IO board, but when I connect with usb, I had breaks with ramps 1.4 and when I reinstall it, it sees it but cannot connect.
Note1: Repertier Server 1.4.1 is installed
Note2: I copied the CM4 IO usb activation code to the bottom of the config.txt file. "dtoverlay=dwc2,dr_mode=host".

screenshot;
https://resimyukle.io/r/JDzqMXYNZR
https://resimyukle.io/r/YyeHNJauw3

Comments

  • As you see you are already using a print "p" with same port that is already connected. Is that correct or is that just the wizard seeing it self during test? If it is true - 2 softwares connecting same port will not correctly work.
  • Checking the linux dmesg and/or syslog would also be useful. Could be a CM Board hardware issue, that has nothing to do with Repetier.
  • Yes, it will retry as long as it sees the port. I also see it is the only one.
    You should check /boot/cmdline.txt

    by default linux uses first serial for console as well, so they could interfere. We normally remove this in our images, but if you have something like "console=serial0,115200" it is using serial for console as well.

    For /boot/config.txt check where you wrote it - there are sections that are only for special pi version. Also see
    https://www.raspberrypi.com/documentation/computers/configuration.html

    CM1, CM3, CM3+ and CM4

    The first generation Compute Module, together with Compute Module 3 and Compute Module 3+ each have two UARTs, while Compute Module 4 has six UARTs as described above.

    On all models of Compute Module, the UARTs are disabled by default and can be explicitly enabled using a device tree overlay. You may also specify which GPIO pins to use, for example:

    dtoverlay=uart1,txd1_pin=32,rxd1_pin=33
  • Repetier said:
    Yes, it will retry as long as it sees the port. I also see it is the only one.
    You should check /boot/cmdline.txt

    by default linux uses first serial for console as well, so they could interfere. We normally remove this in our images, but if you have something like "console=serial0,115200" it is using serial for console as well.

    For /boot/config.txt check where you wrote it - there are sections that are only for special pi version. Also see
    https://www.raspberrypi.com/documentation/computers/configuration.html

    CM1, CM3, CM3+ and CM4

    The first generation Compute Module, together with Compute Module 3 and Compute Module 3+ each have two UARTs, while Compute Module 4 has six UARTs as described above.

    On all models of Compute Module, the UARTs are disabled by default and can be explicitly enabled using a device tree overlay. You may also specify which GPIO pins to use, for example:

    dtoverlay=uart1,txd1_pin=32,rxd1_pin=33
    I made some changes but still couldn't get it to work. Can you tell me which line of code I should add?
  • Not really. I have no cm at all and only did it so far with a pi0 where it worked with what we have on config.txt. So anything I say would be guessing which tutorial I found with google looks good. Actually I would ask google for the cm type you have with "serial gpio uart dtoverlay" as keywords to figure it out.
Sign In or Register to comment.