Slic3r GUI does not work in Repetier-Host


I have just a problem about the activation of Slic3r GUI in Repetier-Host.

My OS is Linux Debian ver. 10 (Buster) and I have installed Repetier-Host version 085b directly from the Debian repository.
The installation was worked out w/o problem, but the slic3r is not available.
So I have also installed from the same repository Slic3r ver. 1.3.0., but the Repetier-Host is not able to open the GUI.
If I use the button "Slice with Slic3r" with .stl file already loaded a small window is opened in very short time and the Gcode is generated.
I guess, the Slic3r is activating the command line version of Slic3r but no GUi is available and the configuration button of Slic3r also does not work.

More info about that.
The GUI also of Slic3r does not work, only the command line works fine, but of course a GUI would be better

I have searched in the forum and in Internet possible similar problem related both to Repieter Host and Slic3r, unfortunately without success up to now.

Could someone help me to solve this problem?

Many thanks in advance for helping me


  • Use a recent host and download recent PrusaSlicer on linux. slic3r is not developed any more as far as I can say. PrusaSlicer is based on it but with tons of cool improvements and also supported by host. If you download the app version, the slicer is already included and preconfigured.
  • Hello,

    many thanks for the prompt reply.

    I will check it (not immediately, I need a bit time), in case I will be back in this forum

  • Hello,

    just for your information.
    The AppImage 2.2.4 version of Repetier-Host works now and quite well.
    Ok, to be honest, the AppImageLauncher works but sometime with some problem, anyway the program  Repetier-Host can run

    Many thanks for the support and have a nice day

Sign In or Register to comment.