slicer G code always sets fan to 50% S127 no matter the fan setting

I also used to have a gradual fan speed increase which i no longer see.

I use repetier w/ the cura slicer engine for this. Looking at gcode I'm at 50% fan speed after layer 1 and then it turns off at completion. The slicer is just not going past 50% fan speed for some reason 

According to my printer settings i see at .50mm i should be at full fan speed.  Minimum speed shows 10mm/sec



;LAYER:1
M106 S127
G0 F9000 X109.002 Y148.375 Z0.580




And then in my filament setting I can further fine tune this based on layer time, etc.  Mine fan speed is 50% and max is 100%.  Min. layer time is 5 seconds


I just do not see any other fan speed settings that would cause this, anyone
have any idea where else I can look? I also looked in printer settings but found no mention of anything cooling related.

Thanks
Dave

Comments

  • In slicer print settings->Extruder at top you say how to scale cooling up until height xy. Also for some firmwares 127 might be 100%. So check gcode flavour to be repetier/marlin/sprinter.
  • Sorry I'm not sure if I'm in the right place, are you referring to here (See screenshot below)?  I cannot find how to embed or attach an image but the links below are what I'm referring to and what I see.

    This is under CuraEngine settings | Extrusion 
    .https://cfbinc-my.sharepoint.com/:i:/p/dave/EQ7sdjEltzVLq5ofY4jmBIMBzlMQvWJWdyajEwSEMxXssQ?e=doUpbO

    Under config | printer settings | extruder I see this but see no mentions of any layer height vs. fan speed.
    https://cfbinc-my.sharepoint.com/:i:/p/dave/EZ5w2xewj1BBr8rLYf6KDW4BsjC55n-T9mv6HS4WX0QDZw?e=083gmX


    Gcode Flavor does state repetier/marlin/sprinter.


    Thanks much

    Dave









  • Same settings as I have. When I sliced a benchy with it I got a lot of different fan settings. Note that on big objects with long layer time it will disable fan I think as it is far above minimum layer time. Not really sure what the logic of curaengine is here. In PrusaSlicer there is also a setting for that. But should be minimum speed and maximum speed if you approach minimum layer time.
  • edited July 14
    In your previous post you mention

     "In slicer print settings->Extruder at top you say how to scale cooling up until height xy. Also for some firmwares 127 might be 100%. So check gcode flavour to be repetier/marlin/sprinter." 

    I do not see the settings you mention.  Any chance you have a screenshot or a better description where I can find this?

    Dave
  • You already said you have selected the correct one. The one goes up to 255 like it should, so that's not the reason. I have same set and got higher values. Did you try slicing a benchy for comparison? And then in g-code editor search for M106 you should get several hits. You can skip through search results with F3.
  • edited July 14
    I did search for M106 for my original STL in cura and the only instance I saw was layer:1. .  I sliced w/ the slic3r engine and it does ramp up w/multiple M106 commands so something screwy w/ cura (See details below)

    Slicing Benchy w/ slic3r (Within host 2.2.4)  I see the fan go to 234.6 at layer 5, at certain points of print it'll move to 255, 229, 214, etc. depending on time at layer.  So that is working corrently

    Slicing Benchy   w/ Cura(Within host 2.2.4) I also see fan speed changes. which is odd.  Layer 1 (S63), layer 2-199 (S127), layer 201 its full speed (S255). 

    I know it's not your slicer but any idea what setting could cause cura not to abide by fan settings on most of my prints?  Clearly there is some value it is seeing to keep fan at $127.  Bench is no taller than the other prints I was printing so it's not that it's just not high tall enough to get to S255 especially given it should be full speed at layer 5 according to my settings.

    Is it possible i could link you to the STL that i noticed this on and you can see if it slices the same way for you with only one M106 command at layer 2 to S127 (Using Cura engine)?  If you would do this the stl is here:
    https://cfbinc-my.sharepoint.com/:u:/p/dave/EbkNarwtGrdBkmTAQt-7iHoBeSnSFG13qW4EWxKbZrOLVQ?e=0MTOcC


    Thanks
    Dave
  • I got the same result. Analysis showed layer time was always > 40s so higher than minimum layer time set in filament. When I increased that time to 200s I got fan speeds of 255.

    For benchy especially the small cylinder at top causes low layer times increasing fan.
  • Repetier said:
    I got the same result. Analysis showed layer time was always > 40s so higher than minimum layer time set in filament. When I increased that time to 200s I got fan speeds of 255.

    For benchy especially the small cylinder at top causes low layer times increasing fan.
    Thank you for taking the time to do that. I guess I just don't understand the logic.  If the slicer says fan at max at a certain layer height what criteria it is using to determine to run it at defined min speed (S127).  Perhaps that means that's just the minimum layer height for the algorithm to ALLOW max fan, not set it to max fan?

    Dave
  • In print settings max. means the maximum it would normally run at, not maximum speed. Logic is that close to bed you need more heat to stick to bed, so fan on is a problem. The higher you get the more cooling you need for small parts as otherwise you print on still semi fluid filament which is what you want to prevent with fan and minimum time so last layer is hard before putting next layer on it.
  • So those settings just defining mix/max potential RPM via PWM?  The slicer determines everything else (Staying w/in those min/max guidelines) in it's slicing calks?

    Thanks for all the info,
    Dave
Sign In or Register to comment.