repetier server not recognizing usb

I am trying to setup repetier server on an ubuntu laptop. the printer that I'm having troubles with is a longer lk4 that I am connecting via serial port.  my issue is that repetier does not recognize the port that my printer is connected to. Ive tried dev/tty.USB0,    dev/tty0,  dev/tty, and none of them works.  when I unplug and plug in the usb it shows that the printer is conncted to  /dev/serial/by-path/pci-0000:00:15.0-usb-0:2:1.0-port0. but only for a split second (barely long enough for me to click on it) and then it dissapears.   what in the world is going on? Ive tried installing ubuntu additional drivers, but still not working.   also the dropdown list of devices/ports gives me like over a hundred options from dev/tty  all the way up to dev/tty63. then from dev/ttyS0 up to dev/ttyS31.  it also give me dev/ttyprintk,    dev/pts/ptmx,      dev/ptx/0      and virtual/delta    and virtua;/cartesian.    Ive tried many of these and none work.

Comments

  • Hello. 
    Please select the devices beginning with /dev/serial/by-id or /dev/serial/by-path.
    Make sure that you always attach the printer to the same port when using the /dev/serial/by-path method

    For your disappearing issues: Please make sure that the baud rate is correct. If it is, could you show us the system log and the server log? 
Sign In or Register to comment.