Help with start script ?

not sure why but every time i start a new print after one has finished, everything is fine until it starts to print the prime line, then it acts as though it is set to absolute positioning without homing and starts to grind all motors and extrude filament until i reset the printer. 
this is my start Gcode so not sure why it is doing that because if i reset the printer the same code runs fine, it is just after a print finished and i start a new print without resetting.. Do i need to add anything to the Run before Job gcodes?  Thank you!

G28; Home all Axis

G92 E0; Reset extruder

M420 S1;

M117 Homing and Leveling

G29 L0 ;Load Mesh slot 0

G29 A ;Activate UBL

G29 J3 ;Probe Bed for mesh tilting

M117; Purging Extruder

G1 Z3.0 F2000; Move Z up before move

G1 X2 Y2 Z0.5; Move to start position

G1 X120 Y2 Z0.3 F1000 E20; Draw priming line

G92 E0; Reset Extruder

Comments

  • Hello. Did you have a look on your end gcode or in the server events after a print? Maybe there is a gcode to set te printer to absolute

  • edited June 7
    Hello, yes Run after Job is blank and Run if job is aborted has my end gcode, maybe that is the issue? should i just use @stopPrint?  problem is if i cancel the print something has gone wrong so i probably want the nozzle to move up and out of the way as well as present the bed and turn everything off asap.
    ; Sample stop code - modify to your needs!
    G91; relative positioning
    G1 Z5 F3000 ; move z up little to prevent scratching of print
    G1 X20 G1 Y125 F2000 ;Prepare for part removal
    G90 ; Absolute Positioning
    G0 E-4 f3000 ; retract 3mm of filament
    M104 S0 ;Turn off extruder
    M140 S0 ;Turn off bed
    M107 ; Turn off fan
    M84 ; Disable Steppers 

    note, yesterday after posting i noticed i did not have a G90 in my end gcode, not sure it matters for the next print so i added it there as well as start gcode

    G90 ; use absolute coordinates

    M83 ; extruder relative mode

  • edited June 7
    i did correct the G0 E-4 to G1 E-4 as well as the redundant G1 in part removal.
  • G90 ; Absolute Positioning
    G0 E-4 f3000 ; retract 3mm of filament

    Think you should add a

    G92 E0 before
    G0 E-4 f3000

    or place the G90 after
    G0 E-4 f3000


  • edited June 7
    RAyWB said:
    G90 ; Absolute Positioning
    G0 E-4 f3000 ; retract 3mm of filament

    Think you should add a

    G92 E0 before
    G0 E-4 f3000

    or place the G90 after
    G0 E-4 f3000


    Thanks, this is what i have now, seems much better, not sure what was causing it but i can now cancel a job and start another without the printer going nuts, note to self; don't piece together start and end gcodes without verifying moves.

    G91; relative positioning

    G1 X80 Y100 Z5 F3000 ; move z up and away

    G92 E0 ; reset extruder

    G0 E-6 ; retract 6mm

    G90 ; Absolute positioning

    M104 S0 ;Turn off extruder

    M140 S0 ;Turn off bed

    M107 ; Turn off fan

    M84 ; Disable Steppers

    M300 S440 P100

    M300 S440 P200

  • Think there is still a mistake as at the beginning you just want to lift z by 5mm  and bring extruder to another
    position.
    doing this by relative move is ok for z but as i guess you never know where x and y are (may be close to printers limits) you should move to a defined position.

    for me it should look like :

    G92 E0 ; reset extruder

    G0 E-6 ; retract 6mm

    G91; relative positioning

    G1 Z5 F3000 ; move z up

    G90 ; Absolute positioning

    G1 X0 Y0 F3000 ; move x and y to defined position

    M104 S0 ;Turn off extruder

    M140 S0 ;Turn off bed

    M107 ; Turn off fan

    M84 ; Disable Steppers

    M300 S440 P100

    M300 S440 P200






  • edited June 7
    RAyWB said:
    Think there is still a mistake as at the beginning you just want to lift z by 5mm  and bring extruder to another
    position.
    doing this by relative move is ok for z but as i guess you never know where x and y are (may be close to printers limits) you should move to a defined position.

    for me it should look like :

    G92 E0 ; reset extruder

    G0 E-6 ; retract 6mm

    G91; relative positioning

    G1 Z5 F3000 ; move z up

    G90 ; Absolute positioning

    G1 X0 Y0 F3000 ; move x and y to defined position

    M104 S0 ;Turn off extruder

    M140 S0 ;Turn off bed

    M107 ; Turn off fan

    M84 ; Disable Steppers

    M300 S440 P100

    M300 S440 P200






    Thank you!, amazing what moving one line of code will do! it will quite literally make or break you. now if i can get it to stop waiting for the extruder to heat up that would be great,
    M104 S[first_layer_temperature] ; start nozzle heating but don't wait
    worked once and never again..
  • command M104   just sets nozzle temperature without waiting

    M109 sets nozzle temperature and waits , that is what you want

    refer to :



  • edited June 7
    yea, i do not want it to wait, since i do UBL and tilt the mesh before printing along with prime line, i prefer not to wait for nozzle to heat up. but thanks, checking out link now, also per Marlinfw.org, 
    M104 - Set a new target hot end temperature and continue without waiting.
Sign In or Register to comment.