PI400 Uinstall

I put the latest Repetier Server on my PI 400 and it's been working flawlessly for a week now. Almost 100 hrs of printing. Today all I get it comm time outs, resends, etc. I wasn't sure if it was going to work on a PI 400, so I kept my backup on a PI3 just in case.

The question is how do I remove Repetier Server from the PI 400?

Comments

  • If you have pro license, deactivate it in register.

    In linux debian you use 
    sudo apt remove repetier-server
    to uninstall the app. It leaves still /vat/lib/Repetier-Server with all your settings and data. You can remove them with
    sudo rm -r /var/lib/Repetier-Server
    if you are sure you don't need the settings any more.

    BTW: If it worked fine and you suddenly get timeouts you might have changed something adding electronic problems. Other position, cables crossing other cables, different usb cable, other usb port, ... 
  • I have a Pro license and I always make sure I cancel it first when changing PI's or doing my PI tests.

    Thanks for the instructions on removal as well. I think I tried every combination of commands I could think of to remove it, except, of course, the correct one... I am leaving the data and settings alone for the moment.

    As for the changes, the PI 400 doesn't have enough USB ports for the two printers I am running from it. It only has 3 USB ports (USB 2 x 1, USB 3 x 2). I have a PI 400 Mouse, USB 3 2T SSD, USB 3 powered hub. The printers connect to the USB 3 powered hub.

    Your suggestion got me thinking and the only thing I changed was I added a 1M USB 3 extension cable from the PI400 to the powered HUB. Before that, all the printing I was doing had the hubs built in cable connected directly to the PI 400 (it's a very short cable).

    The PI3 I have as a back up, I had deactivated the license before installing on the PI400. The PI 3 setup has printed successfully for a year and hundreds of hours to an AnyCubic Chiron with the latest Marlin 2.0.9.3 firmware on it (I modified the firmware in places for what I need from the printer).

    The new printer I added is an AnyCubic Kobra Max and the firmware is not available, but it seems to be based on some Marlin bug-fix version from Dec 2021 (probably their Vyper base would be my guess).

    I checked the console on the PI 3 to the Kobra Max and below is what I see now. I get about 3 or 4 of those as the print starts and then it settles down and prints normally for the remainder of the print. So it's just the initial toss back and forth to start with. With the PI400, I'd see a dozen or more of the same messages and the print head would print like a drunken sailor where ever it wanted.

    Hence I'm forming the opinion that there's something amiss in the firmware with the Kobra Max that needs a good swift kick in the C. Any thoughts or suggestions would be super appreciated.
    Mesg:10:14:57.859: Warning: Communication timeout - resetting communication buffer.
    Mesg:10:14:57.859: Connection status: Buffered:82, Manual Commands: 0, Job Commands: 5000
    Mesg:10:14:57.859: Buffer used:82 Enforced free byte:41 lines stored:2
  • If it is just at the start timeout maybe too low. Can happen if firmware has busy support disabled or one slow command does not send "busy" while taking longer than 2s. Should be easy to spot if you log and see the last 15 commands before timeout. Might be homing, heating or bed leveling for example.
  • The Kobra Max has busy support disabled, heating the bed up to 80C for PETG takes just shy of 11 minutes. Then the nozzle heats up in about 2 minutes. There's no bed levelling so the start sequence is heat bed, heat nozzle, purge some filament, do a prime line, then the real print. Using PRUSA Slicer.

    Its almost like the firmware gets all caught up in doing something and just ignores whatever is coming in, and then catches up but then it's out of sync so between the server and firmware it's a blind folded sync battle.

    Would it help to increase the time out seconds to say a week or so...LOL
  • edited May 30
    Testing more today with the standard PI 3 that I've been using for months with another printer. I'm pretty sure it's not a problem with Repetier Server Pro now, more the printer and whatever serial setup they are using in the firmware.

    Both cases of RSP resulted in initial errors (the PI400 had many more than the PI3). I've used unpowered hubs, powered hubs, USB 2 and 3 cables of various lengths and nothing seems to help at the start of the print.

    Once it makes it past the "errors" and resends, the whole thing settles down to the send and OK and it runs for 10 hrs for my print jobs no issues at all. It's just the initial communication.
    Send:19:40:00.586: N91 G1 X19.344 Y188.104 E71.19539
    Recv:19:40:00.756: ok
    Send:19:40:00.756: N92 G1 X20.138 Y186.186 E71.28744
    Recv:19:40:00.925: ok
    Send:19:40:00.926: N93 G1 X23.072 Y183.254 E71.47142
    Mesg:19:40:06.933: Warning: Communication timeout - resetting communication buffer.
    Mesg:19:40:06.933: Connection status: Buffered:74, Manual Commands: 0, Job Commands: 5000
    Mesg:19:40:06.933: Buffer used:74 Enforced free byte:37 lines stored:2
    Send:19:40:06.933: N94 G1 X24.909 Y182.484 E71.55977
    Send:19:40:06.933: N95 G1 X24.968 Y182.816 F10800
    Send:19:40:06.934: N96 G1 F1800
    Recv:19:40:11.583: ok
    Send:19:40:11.583: N97 G1 X277.125 Y180.544 E82.7446
    Recv:19:40:11.751: ok
    Send:19:40:11.751: N98 G1 X363.607 Y180.544 E86.5805
    Recv:19:40:12.085: ok (2)
    Send:19:40:12.085: N99 G1 X365.273 Y181.233 E86.66046
    Recv:19:40:12.090: Error:checksum mismatch, Last Line: 93
    Recv:19:40:12.090: Resend: 94
    Recv:19:40:12.093: Ignore due to resend: ok
    Recv:19:40:12.107: Waiting for resend requests finished. Starting resends ...
    Send:19:40:12.107: Resend: N94 G1 X24.909 Y182.484 E71.55977
    Recv:19:40:12.586: ok
    Send:19:40:12.586: Resend: N95 G1 X24.968 Y182.816 F10800
    Recv:19:40:12.752: ok
    Send:19:40:12.753: Resend: N96 G1 F1800
    Recv:19:40:12.922: ok
    Send:19:40:12.922: Resend: N97 G1 X277.125 Y180.544 E82.7446
    Recv:19:40:12.924: echo:Unknown command: "9 G1 X365.273 Y181.233 E86.66046"
    Recv:19:40:12.924: ok
    This is the printers default options at startup:

    Recv:19:26:04.869: FIRMWARE_NAME:Marlin bugfix-2.0.x (Dec 27 2021 18:16:29) SOURCE_CODE_URL:github.com/MarlinFirmware/Marlin PROTOCOL_VERSION:1.0 MACHINE_TYPE:Anycubic Viper EXTRUDER_COUNT:1 UUID:cede2a2f-41a2-4748-9b12-c55c62f367ff
    Recv:19:26:04.871: Cap:SERIAL_XON_XOFF:0
    Recv:19:26:04.874: Cap:BINARY_FILE_TRANSFER:0
    Recv:19:26:04.874: Cap:EEPROM:1
    Recv:19:26:04.878: Cap:VOLUMETRIC:1
    Recv:19:26:04.878: Cap:AUTOREPORT_TEMP:1
    Recv:19:26:04.880: Cap:PROGRESS:0
    Recv:19:26:04.880: Cap:PRINT_JOB:1
    Recv:19:26:04.883: Cap:AUTOLEVEL:1
    Recv:19:26:04.883: Cap:RUNOUT:1
    Recv:19:26:04.887: Cap:Z_PROBE:1
    Recv:19:26:04.889: Cap:LEVELING_DATA:1
    Recv:19:26:04.890: Cap:BUILD_PERCENT:0
    Recv:19:26:04.892: Cap:SOFTWARE_POWER:0
    Recv:19:26:04.896: Cap:TOGGLE_LIGHTS:1
    Recv:19:26:04.896: Cap:CASE_LIGHT_BRIGHTNESS:0
    Recv:19:26:04.898: Cap:EMERGENCY_PARSER:1
    Recv:19:26:04.901: Cap:PROMPT_SUPPORT:0
    Recv:19:26:04.901: Cap:SDCARD:1
    Recv:19:26:04.905: Cap:REPEAT:1
    Recv:19:26:04.908: Cap:AUTOREPORT_SD_STATUS:0
    Recv:19:26:04.909: Cap:LONG_FILENAME:1
    Recv:19:26:04.910: Cap:THERMAL_PROTECTION:1
    Recv:19:26:04.914: Cap:MOTION_MODES:0
    Recv:19:26:04.914: Cap:ARCS:1
    Recv:19:26:04.917: Cap:BABYSTEPPING:1
    Recv:19:26:04.919: Cap:CHAMBER_TEMPERATURE:0
    I know it says AnyCubic Viper, but the printer it's installed on is brand new from factory and a stock AnyCubic Kobra Max.

  • There is no indication if busy is enabled or not. Disable ACK in console and run a G28 when axis start a good part away from homing position. If you see "busy" in console it has support. At the date at least marlin supported it but all we see is compile date, so still might a base not having it.

    The wrong timeout is causing a buffer overflow causing the following checksum error. So that is just a sequence and is no real server issue as it also gets corrected correctly. Wait bed temp is known to be slow, so no cause for timeout.

    What is your timeout setting? Normal is 3s with busy and 30s without. A week makes no sense - you want a timeout on real communciation timeouts to safe your print. So if that is the only one at the start it seems also fine to keep it. Only if you get them during print as well, check if this is because of slow long moves and increase to catch them as well. 
  • I was kidding on the "week timeout"... but I did so some more tests today and what I found was if my prime lines were up in the 300mm range, I would get the sequence of time outs. But only on the first layer because of the slow speed. With a smaller print, I would only get 1 or 2 timeouts. None the less from the Pi3 I used before it's working perfectly.

    My timeout is set for 5 seconds for this printer, 3 for all my others and the errors are only from this printer. My AnyCubic Chiron, PRUSA MK3S/MMU2S and two deltas (scratch built) don't do this at all. The Anycubic Kobra Max is a brand new printer with just introduced new motherboard 32 bit M4 processor.

    I also checked for the busy as you outlined and can confirm there is none.

    Repetier Server Pro has been rock solid for me since the day I started using it. Which is why I'm inclined to have my doubts about the printers firmware/hardware.

    Thanks greatly for your software and support!
Sign In or Register to comment.