No WIFI device on Raspberry PI 4

edited May 2022 in Repetier-Server
Hello, I have this problem, when I start REPETIER I no longer have any wifi connection in the WLAN settings I get this message: NO WLAN ADAPTER INSTALLED (the configuration is Repetier Server Pro 1.3.0 on Raspberri PI 4).
Kindly how can I solve Thanks


  • This actually just means that iwconfig does not report a wifi device for wlan0. It sounds like it worked before so first try would be reboot and next is the question what you did between where it worked and when it stopped working?

    When you login (use ethernet cable as long as it does not work), what does

    Also after reboot run
    to see messages during bootup. Maybe they contain a hint on the problem.

    If you have a extra sd card, install image on new sd card and see if it happens there as well. If not copy your server installation (e.g.  Repetier-Server Monitor) to new card. Maybe just some defects on sd card made it break. Especially if you did nothing like update/config/install extra software.
  • Hi, in the attachment I am sending you an answer to the commands you indicated. Kindly tell me how can I restore the WIFI.Thank's

  • You can not attach files here. Please just copy the text into forum. Should be not too many lines.

    What about the question what you did between working and not working version?
  • I apologize for the publication of the data, I reply that nothing has been done between working and not working version, I inform you that by deleting the repetier server in WLAN and recreating the Repetier server with lan cable the connection works, I still hope you can solve the problem connection in WLAN Thank you
  • Good it works with cable. That way you can easily try the server backup/new sd card solution in case a sd file defect is causing this. Without the logs it is not possible to say more. And even with it might take several iterations of information exchange to find what got corrupt, that is why new sd card and copy all data is normally much faster.
  • I have this same issue. I managed to drop to command line, use raspi-config to configure a wlan as to run updates, so everything is updated, including Repetier Server (1.4.0 now) but still getting "No WLAN adapter installed". Iwconfig shows the wireless connected to network. While its working now, the issue remains that I can no longer manage the wlan through Repetier.
  • By default we check wlan0 but you can change that. If wlan0 does not exist you get just that. But we are not using the regular linux method on pi - we change the active config with our script or switch to ap if defined to do so and switch back when we see a known connection. Something linux normally does not do. So you need to decide manual solution or server solution. Both is not possible due to implementation changes. Note that you can define manual config in /boot as described on download page.
Sign In or Register to comment.