Mesh Bed Leveling

So i own a Anycubic i3Mega S and Repetier-Server-Pro. I did a mesh bed leveling on my Firmware on the anycub(Marlin). When I print something over repetier Server it just ignores the mesh bed leveling, but when I print the Same g,Code directly with an sd card it works. Do I have to do a mesh bed leveling with repetier Server as well, when yes where?”

thanks for answers

Comments

  • There is no difference between sd printing and server printing regarding mesh leveling. The only question is if the result is stored in eeprom so it is permanent or if it gets lost on reset/power out. It is just G29 with proper parameter matching your printer or just default G29. You cal also add mesh leveling in the start g code if you want it before every print. But we do internally nothing - all that our mesh leveling button does is sending G29 to printer firmware and the printer does all the work.
  • I mean the i3 Mega s does not have a auto leveling function. You have to do it from Hand in the Merlin software and write a line in the G-Code of your sliced Modell before print. Cura does write that line for me but every time i print over the SD-Card it prints like the Bed is leveld and every time i print over repetier Server it just seems to ignore it(presses the noodle in the bed). I tried it with the same file
  • Which server version are you using?
    Can you show the code part that gets ignored?
    If you activate logging you should see if it gets send or not.

    If not: Server has many methods to modify g-code so also check in printer config->g-codes->replacements if you have a rule that matches your leveling g-code and replaces it. By default they are empty, but maybe you have added something there-
  • edited May 4
    Im using Repetier Server Pro 1.3.0-Lunos-70

    Here is the full Start G-Code standart used by Cura

    G21 ; metric values

    G90 ; absolute positioning

    M82 ; set extruder to absolute mode

    M107 ; start with the fan off

    M140 S{material_bed_temperature_layer_0} ; Start heating the bed

    G4 S60 ; wait 1 minute

    M104 S{material_initial_print_temperature} ; start heating the hot end

    M190 S{material_bed_temperature_layer_0} ; wait for bed

    M109 S{material_initial_print_temperature} ; wait for hotend

    M300 S1000 P500 ; BEEP heating done

    G28 X0 Y10 Z0 ; move X/Y to min endstops

    M501 

    M420 S1 

    M420 Z2.0 ; Set leveling fading height to 2 mm

    G0 Z0.15 ; lift nozzle a bit

    G92 E0 ; zero the extruded length

    G1 X50 E25 F500 ; Extrude 25mm of filament in a 5cm line.

    G92 E0 ; zero the extruded length again

    G1 E-2 F500 ; Retract a little

    G1 X120 F4000 ; Quickly wipe away from the filament line


    The two bold lines are responsible, that Marlin uses the Mesh Bed Leveling that i manually put in. (I think its even something saved to the EProm).


    I just activated Logs and i will try tomorrow what it says. I just saw it because at my first print after 9 hours Repetier server just randomely stoppen and said it was still going. The next Print it printed it fully but its how i said it doesnt takes the leveling i did


    PS: Sorry for my english its not the best

  • No bold lines but assume you mean M420
    https://marlinfw.org/docs/gcode/M420.html

    You can try adding
    M420 V1
    after that. That would write the leveling active which should be what you stored. It is is all 0 than the commands do not work as expected.
    G28 is before this which is good as it disables leveling unless configured to not do so.
  • Hi, sorry for the Trouble found the mistake. Somehow when i plugged the rasperry Pi in the first time it deleted the leveling. i just leveld it again and now it works perfectly fine. I love Repetier Server btw its great.
Sign In or Register to comment.