Problems with Waveshare 10.1 Inch (H) Display + Rpi4

Hello Guys!

im struggling now for days to get the Touchscreen working...

-Raspberry Pi4, 64gb SD Card (Powersupply is good)
-Waveshare 10.1 Inch Display (H) with Case.

First Setup @ config.txt:
hdmi_cvt 1024 600 60 6 0 0 0
First Problem was: Just the Boot Logo shows up, after some seconds it dissapear, than Black Screen forever.

Than got the Drivers from Waveshare:

git clone
cd LCD-show/
sudo ./LCD101-1024x600-show

Now after the Boot Logo i have a Console. But nothing happens, beside the console Logs.
It stops at "Started: Update UTMP about System RunLevel Changes"

i tried your posted solution:
sudo nano /usr/share/X11/xorg.conf.d/99-fbturbo.conf
Section "Device"
Identifier "mhs35"
Driver     "fbdev"
Option     "fbdev" "/dev/fb1"

My Output is this:

Section "Device" Identifier "Allwinner A10/A13 FBDEV" Driver "fbturbo" Option "fbdev" "/dev/fb1" <--changed from fb0 to fb1

Option "SwapbuffersWait" "true"

This solution does nothing...

Could anybody could help me?
I would really like to test your RepetierServer.
We want to use it in our company, and buy a license after our try.
Looks much more promising as Octo or others..



  • > Now after the Boot Logo i have a Console. But nothing happens, beside the console Logs.
    Does it log in automatically or not? Our system is configured I think that you need pi user to login automatically. Some actions can disable that behaviour.
    Login to console and run
    sudo raspi-config
    It is in boot-options->Desktop /Cli selectable.

    Otherwise login in console and send
    manually and see if you get any error messages.
    I assume you are using our image plus extra action to install the waveshare frame buffer driver.
  • thanks for the reply!
    If i send startx, the response is:
    cannot execute binary file: Exec format error

    if i choose boot option, Desktop i get the response:
    Do sudo apt-get install lightdm to allow configuration of boot to desktop

    and if i try to install this, i get:
    dpkg: unrecoverable fatal error, aborting
    files list file for package libxt6:armhf is missing final newline

    What do you mean with "log in automatically"?
    At the start this morging, my last log in the console of your image is:
    [OK] Started Time & Date Service
    Oops: Terminated

  • Ok, after soem digging I found how we normally start xserver. On bootup we start the script
    It check if $RUN_CHROME is enabled in /boot/repetier-image-setup.txt and if so it starts xserver with
    xinit -- -nocursor 2> /dev/null > /dev/null &
    This omits all messages, so to test with getting errors you need
    xinit -- -nocursor
    and you will see where it wents wrong.

    We use openbox to reduce memory usage. No auto login is required with current images - that was apperently only the old way.

    So please check xinit above and hope you get no "Exec format error". This means that some executeable is not for your processor or os. Could be that you installed wrong waveshare driver meant for a different os/processor.
  • Hey!

    thank u so much. Ive got it working this morning. Ive done a complete restart, new image download, new unzip, this time with 7zip and a complete reflash. All ive done was editing the config.txt with hdmi modes... no driver installed, nothing else... first bootup-->worked... dont know where the problem was.
    But hey, ive learned a little bit about Linux :D

    Thank u so much. System is super nice! We like it!

    Just one question left. Is there any adress of your licence/Update server?
    Our company have strict out/ingoing routing rules...
    Is it possible too keep the Software offline, besides Licenseserver and or Updateservers?

    Maybe you have some Adresses for me, to whitelist them.

  • License is activated through server, so that needs to be accessible.

    Access is only required for activation.

    You might want to also white list which is used to check for updates and autoupdater to download it. Without this you can also always manually download and run installer like for first install - it will just make it an upgrade as it will not change already installed configs/data - only upgrade to latest format if required.
Sign In or Register to comment.