Temperture set up


First of all, Great Job! I love your software. Just donated $5 I know is not a lot but I hope it will buy I cap of coffee :)

My question is: how can I disable temperature setting that prohibits my printer to start until it hits the perfect temperature ... it 5-7 min to star printing.

I know that my temperature gos up and down a lot, so that my problem.


  • First you need to calibrate your extruder so that it swings around +/- 1°C when target temperature is reached. If you use PID you can use M303 (see doc) to get the PID values. For dead time control measure time between turning on and temperature rise.

    Then use M109 instead of M104 and M190 instead of M140 to set temp. These commands wait until target temperature is reached and only then continue. If you like, you can add additional G4 to wait some more seconds. See http://reprap.org/wiki/G-code for a short overview about gcodes.
  • Hello, again, Thank you for your answear.

    But it is possible to do this in a more simpler way? I do not know how to apply your way of explication.

    With all respect, the problem is that I don't speak your "language' per say :)

    Can you guys help me, a total Newbie.

    I Have version V1.0.06

    Thank you.  

  • In Repetier-Host you disable easy mode and topen log by hitting toggle log in top toolbar. Then you see output from firmware. If you then in manual control enter
    M303 P0 S210
    to calibrate extruder 0 for 210°C. It will then do some heat cycles and outputs values you would set for P, I and D in the erpom configuration for your extruder. Read firmware doc to learn more about eeprom settings and temperature handling.
Sign In or Register to comment.