extruder is not increasing the distance according to the height of each layer

hello, thanks to your help I have been able to finish configuring the printer, when I start printing it is excellent, complete addition to the bed and very good definition in the piece, but when it reaches layer 3 the nozzle leaves marks on the layer, and in layer 4 the nozzle hits the layer causing the bed to move, it is obvious that the extruder is not increasing the distance according to the height of each layer, I have read everything available in chats and Repetier forum and I can not find the solution, I can not find the firmware parameter to modify to solve this problem, can you help me please?

I use the escher bed calibration method, I am printing with layer 0.3, and the printing speed is 60, I am using PLA


  • sorry, I forget, my 3D printer is HE3D K280
  • When you home and send
    G1 Z100 F600
    what is the distance bed-extruder? If it is not 100mm then your steps per mm for z axis is too wrong and must be adjusted. With eeprom support you can simply change the value in eeprom editor.

    If you hear beeping sound on z moves the acceleration or max speed is too high and you loose steps. This can also lead to wrong z positions. Especially with spindle acceleration and max speed is much lower than for x and y while steps per mm is much bigger.

    If Z is moving correctly, the problem is overextruding. You should first calibrate the extruder steps per mm to you know extruding 50mm moves filament exactly 50mm in.

    Next is to adjust slicer multiplier to what is needed for your filament. Often you need factors 0.85-1.0 for extrusion as filament expends a bit or does not take the computed shape after extruding. This is normally just a small part and gets visible with full infill after some mm of print.
  • thanks for your fast answer, I did the test, down the z to 0 and up to 100mm, measured with the digital caliper and is perfect, I have 100mm in the caliper, the bed is calibrated too, I have a great addition of the first layer, I down the flow to 75% and print with same bad results, I don't think that extruder is the problem but is good discart to find the problem, so can you send me a link with info about how calibrate the extruder please?
  • and sorry to bother you, maybe some of questions that I do sounds stupids, but I am not the normal profile for 3d printer enthusiast, I am a 52 years old narcotics police with 32 years in servise and sometimes tech stuff are hard for me, but I try to do my best every single day, I love this printer, it's amazing and I'll try until I'll done, we old people have a great treasure: the patience
  • trying to follow the calibration guide that you send me, Pronterface don't recognize the command M503, 
    ok 0
    >>> M503
    ok 0
    Unknown command:M503
    ok 0

    trying the same in Repetier and same pproblem
    15:16:46.341 : DebugLevel:6
    15:16:46.344 : SelectExtruder:0
    15:18:21.210 : Unknown command:N15 M503

    my firmware is Repetier 1.0.4
  • No need to use pronterface. That is just the host software the author used. Any host also Repetier-Host and Repetier-Server would work. There you have an eeprom editor so you can interactively change the setting.

    Question is if you compiled the firmware with EEPROM_MODE 0 or not. Only if it is not 0 you have eeprom support. As you see here:
    M503 is no command in repetier-firmware, we use
    to show eeprom settings. Please use the eeprom editor to change it. The example is for marlin I guess. The important part I wanted to show is the way calibration works. Did not expect you to not use just the editor to change the setting.
  • you're a genius, thanks to all your help I am 98% done, ! did the calibration of the extruder, when I mark 10cm in the filament and run G1 E100 F100 the extruder avance 10cm exactry and now the printed looks great at 0.2 layer, I did the 2cm cube without fill to calibrate the flow as well, the printer print the cube without problems, the 2% that I missing is the obtruction of the nozzle, with those new parameters and all calibrated, when I try to print something more complex that flow cube calibration I have  nozzle obstructions, I know that I must play with the printer parameters for a while, any clue could be very apreciate, and thank you again for all your help
  • Good that it is working good now. First layer can be critical if z is too low at start so you have extra pressure on nozzle making it hard to extrude correctly. At z = 0 you should be able to move a paper below hot nozzle with just a bit of friction then z is correctly calibrated.

    Also make sure temperature is good for your filament. If you extruder faster with colder filament it might block. If you print with temperature too hot extruder might block. Fortunately filaments tell you proper temperature and you might just select x degree higher then min value to compensate speed and temperature deviation.
  • Hello, please excuse my absence, I was on a mission in the jungle of Costa Rica for almost 3 months, yesterday I returned home and I want to resume the pending configuration for the k280, I did some printing tests and it continues to clog the nozzle

    Following your advice, I put my attention on the temperature, a friend lent me his AN9002 tester with thermometer, I heated the extruder to 200 C, in repeater and on the screen of the k280 it says 200 C, but the tester shows 170 C , this is the reason for the clogging of the nozzle, the PLA needs 180-200 C to work well

    The reverse happens with the bed, I heat the bed to 60 C, and the tester shows 102 C

    I ran many times the auto calibration with M303 E0 S200 C0 X0 but it doesn't solve the problem, the tester still shows 170 C when repeated and the screen of the k280 shows 200 C

    I can change the P I and D values ​​in the EEprom editor, but I have no idea how to put the correct values ​​in those fields, nor do I know the relationship between these three values ​​and how they affect each other.

    Any help you can give me is welcome.
  • EEprom bed settings:
    Bed Preheat Temp: 60 C
    Bed Heat Manager: 1
    Bed PID drive max: 255
    Bed PID drive min: 20
    Bed PID P-gain: 98
    Bed PID I-gain: 16.5
    Bed PID D-gain: 145
    Bed PID max value: 255

    EEprom extruder settings:
    Bed Preheat Temp: 255 C
    Bed Heat Manager: 1
    Bed PID drive max: 255
    Bed PID drive min: 20
    Bed PID P-gain: 7
    Bed PID I-gain: 2
    Bed PID D-gain: 40
    Bed PID max value: 255
  • The problem is not with M303 I guess. If firmware says 200°C it measured this. This includes the position where the sensor is and also the precision error for the sensor.

    Assuming AN9002 is a infrared mesurement it also has error sources. Precision depends a bit on the material and also has own error plus you measure a different point. Sensor is internal where it is hotter than on the outer surface.

    Anyhow only solution to get it hotter is to increase extruder temperature so it satisfies the material temperature regardless of what it shows. So to say to fix the measurement error.
  • thanks, it's a phisical contact between tester and nozzle block trough a thermocouple, and the difference between tester and firmware measure  is 50 C plus

    Great sugestion up the temp at tester shows 200 C, same with the bed, but in the nozzle I can't, the firmware have a 250 C limit (170 C in the tester) and I can't go up, can you help me to up the limit please ?

    in my previous message you'll see the values that I have in the EEprom, sorry second block of values is extruder not bed, and for printer setup I have:
    in printer tab extruder preheat temp 255 C, bed preheat temp 60 C
    in extruder tab max extruder temp 255 C, max bed temp 255 C

    I tried to up the values for max and prehead, but don't show the increase in manual control tab of repetier, keep showing 250 C as top heat

  • another question, everybody told me that chance the firmware to marlin, they said that marlin is better firmware, I got a marlin firmware fot k280, but I am scare about it, Is repetier compatible with marlin firmware? are you agree with this change? you're the expert and what you say is mandatory for me
  • Don't know what firmware is on K280 but marlin is nor problem for our software. It is the most widespread firmware and many printers also use it with different names. For many sold printers I have seen alternative marlin firmware and often is is better configured - be it using a newer version or by activating additional features that were disabled by vendor. As long as you have a vendor binary to update to original the risk is relatively low if the pre configured version is known to work on your model. 

    50°C is a big difference. Is this the original thermistor? If firmware was configured for a different thermistor the difference will grow the more you move away from 25°C where the typically used all have 100k resistance. That is why it is important to select the correct one so resistance-temperature curve matches.

    Anyhow in server/host you can increase max temperature, but that does just allow setting higher values. The firmware has it's independent limit and needs to be configured there and it could be that it is a compile time limit so you need to compile printer firmware your self.
Sign In or Register to comment.