Optimierte Kommunikation schlägt fehl und Drucker bleibt stehen.

Hallo,

ich habe mir gestern den Server auf einem PI 3b+ installiert. Soweit so gut. Allerdings erhalte ich beim einrichten des Druckers (Voxelab Aquila X2) nachfolgendes Bild

[URL=https://bilderupload.org/bild/4e2a21494-fehler][IMG]https://bilderupload.org/image/thumbnail/resized-4e2a21494-fehler.jpg[/IMG][/URL]

Ich würde vermuten (bin aber nicht sicher) es liegt am USB Kabel. 

Weitere Einrichtung hat problemlos funktioniert. Allerdings wenn ich einen Druck starte, bleibt er in der 2. Schicht stehen schiebt ca 10mm Filament nach und hört dann auf zu drucken. Kann das vielleicht sein, weil die SD Karte noch drin gesteckt hat im Drucker?

Viele Grüße
Kev

Comments

  • edited January 11
    Sry fürs einbinden den Bilds war ich ich zu doof

    https://bilderupload.org/bild/4e2a21494-fehler

    und fürs editieren auch -.-
  • Da ist wohl eher keine Kommunikation. Ping-Pong 22 Zeilen/s ist ja schon mieß - normal ist was über 100. Da ist also etwas in den Kommunikationeinstellungen falsch - falsche Baudrate oder gar falsche Firmware. Manual schweigt sich da leider aus und nennt auch keine Parameter wie Baudrate. Würde erst mal mit ping pong verbinden (Marlin als firmware) und in die Konsole wechseln und sehen ob man nach Eingabe von
    M115
    etwas sehen kann das weiterhilft. Wenn Firmware erkennbar ist ggf wechseln. Filter auschhalten und sehen ob da irgen was von der Firmware ankommt (recv: zeilen sind vom Drucker).
  • Hi,

    ich habe nun mal das Netzteil vom PI gegen ein Originales getauscht und ein besseres USB Kabel besorgt. Ping Pong mit Baudrate automatisch erkennen hat direkt funktioniert. Nach Eingabe von "M115" kam folgendes raus.

    FIRMWARE_NAME:Marlin 5.1.7 (Nov 30 2021 14:41:13) SOURCE_CODE_URL:https://github.com/MarlinFirmware/Marlin PROTOCOL_VERSION:1.0 MACHINE_TYPE:Voxlab-1 V1 EXTRUDER_COUNT:1 UUID:cede2a2f-41a2-4748-9b12-c55c62f367ff
    Recv:16:35:36.738: Cap:SERIAL_XON_XOFF:1
    Recv:16:35:36.744: Cap:BINARY_FILE_TRANSFER:0
    Recv:16:35:36.744: Cap:EEPROM:1
    Recv:16:35:36.750: Cap:VOLUMETRIC:1
    Recv:16:35:36.751: Cap:AUTOREPORT_TEMP:1
    Recv:16:35:36.757: Cap:PROGRESS:0
    Recv:16:35:36.757: Cap:PRINT_JOB:1
    Recv:16:35:36.763: Cap:AUTOLEVEL:0
    Recv:16:35:36.763: Cap:RUNOUT:0
    Recv:16:35:36.770: Cap:Z_PROBE:0
    Recv:16:35:36.775: Cap:LEVELING_DATA:0
    Recv:16:35:36.775: Cap:BUILD_PERCENT:0
    Recv:16:35:36.781: Cap:SOFTWARE_POWER:0
    Recv:16:35:36.787: Cap:TOGGLE_LIGHTS:0
    Recv:16:35:36.788: Cap:CASE_LIGHT_BRIGHTNESS:0
    Recv:16:35:36.794: Cap:EMERGENCY_PARSER:0
    Recv:16:35:36.800: Cap:PROMPT_SUPPORT:0
    Recv:16:35:36.800: Cap:SDCARD:1
    Recv:16:35:36.806: Cap:AUTOREPORT_SD_STATUS:0
    Recv:16:35:36.811: Cap:LONG_FILENAME:0
    Recv:16:35:36.818: Cap:THERMAL_PROTECTION:1
    Recv:16:35:36.818: Cap:MOTION_MODES:0
    Recv:16:35:36.824: Cap:ARCS:1
    Recv:16:35:36.824: Cap:BABYSTEPPING:1
    Recv:16:35:36.831: Cap:CHAMBER_TEMPERATURE:0


  • Ok Firmware ist also eine Marlin mit unbekannter Version (5.xxx gibt es noch nicht, die haben da ihre versionsnummer einfach eingetragen, aber immerhin schon mit Cap Unterstützung). KLappt es denn im ping pong weitgehend fehlerfrei (siehe Konsole)? Wie schnell ist die Geschwindigkeit wenn du nur die aktive Konfiguration mit ping pong testest? 
  • Ich glaube der Drucker ist irgendwie ungeeignet dafür.
    Wenn ich über den Server Drucke, kommt nur mist dabei raus <span>:disappointed:</span>

    [quote]Recv:16:52:17.807: echo:Unknown command: "M73 P6 R151 Q6 S151"
    Recv:16:52:17.827: echo:M109 Invalid extruder 1
    Recv:16:52:17.848: X:0.0000 Y:0.0000 Z:50.0000 E:0.0000 Count X:0 Y:0 Z:20000
    Recv:16:52:17.891: Error:checksum mismatch, Last Line: 239
    Recv:16:52:17.891: Resend: 240
    Recv:16:52:36.899: Error:Line Number is not Last Line Number+1, Last Line: 266
    Recv:16:52:36.899: Resend: 267
    Recv:16:52:37.444: Error:Line Number is not Last Line Number+1, Last Line: 271
    Recv:16:52:37.452: Resend: 272
    Mesg:16:53:18.855: Warning: Seems like we missed a ok - continue sending.
    Recv:16:53:18.874: Error:checksum mismatch, Last Line: 311
    Recv:16:53:18.874: Resend: 312
    Recv:16:53:18.916: Error:Line Number is not Last Line Number+1, Last Line: 311
    Recv:16:53:18.916: Resend: 312
    Recv:16:55:49.912: Error:Line Number is not Last Line Number+1, Last Line: 436
    Recv:16:55:49.912: Resend: 437
    Recv:16:55:59.914: Error:Line Number is not Last Line Number+1, Last Line: 439
    Recv:16:55:59.914: Resend: 440[/quote]


  • Und jetzt ist er wieder einfach stehen geblieben. 

    Mesg:17:19:49.826: Warning: Seems like we missed a ok - continue sending.
    Recv:17:20:32.759: echo:TE 02 20N1327 G1 X21.70 Y82 E81.5
  • Prinzipiell ist er geeignet, aber die Fehlerrate in der Kommunikation scheint schon recht hoch zu sein. Frage ist also ob es hier Störquellen gibt wie
    - Langes usb kabel
    - Kabel nicht geschirmt
    - Parallel zu Stromleitungen oder Signalleitungen
    - Exakte baud rate oder nur fast gleich - 230400 und 250000 klappen oft beide halbwegs selbst wenn es die falsche ist, aber mit mehr Fehlern insbesondere bei längeren Zeilen.

    Recv:17:20:32.759: echo:TE 02 20N1327 G1 X21.70 Y82 E81.5

    Das ist allerdings ziemlicher Müll was die Firmware da von sich gibt bzw. ankommt. Als ob hier teile des Eingangspuffers im Ausgang mit gelandet ist.
Sign In or Register to comment.