Extruder/Fan have to be set manually?

I just bought a Longer LK5 Pro right after Thanksgiving and I've been using Repetier Host mostly.  The printer uses SD card out of the box and I was not able to use a PC connection until this weekend because of a power issue with USB 5v.  I just decided to order a hardware blocker, which arrived this weekend.

So far I've been able to print successfully, in fact most of my prints have come out decent, not great, but very little failure since I started using a glue stick no the bed.  But one thing that has consistently been a problem is that I have to manually set the heat on the extruder and manuallly set the fan rate.

I tried my first print tonight directly from Repetier-Host to the Printer without using the SD Card (now that I'm connected to the PC) and it sent the print over fine, but again the extruder wasn't heating up and the fan did not turn on, despite being set to 220 and 100 respectively in Repetier-Host's software.

What am I doing wrong?

Comments

  • Enable expert mode (disable easy mode) and check if debug mode is enabled in manual controls. This stops extruders from working so you can test things. That would normally be the only reason heating does not work. Make sure in printer settings you enabled pulling temperatures otherwise it might be heating and you don't see it.

    Also see log window for messages - if firmware has problems it might disable heating as well and will report reason. Normally it is one of these.
  • Debug mode had "info" and "errors" checked.  I removed them, clicked ok.  I dont' see anything in the window log indicating errors.

    Same results.  Bed began to warm up accordingly (set to 60 degrees), but the nozzle kept hovering around 23.80 degrees and went up and down slightly, but not above 24 degrees or anywhere close to the 220 I have it set for PLA.

    If I manually go to "Tune" and set the settings on the LCD, the temperatures rise and Repetier shows the temperature rise accordingly.
  • edited January 2
    Hmm.  I seem to be getting the same issue in Ultimaker Cura.  It isn't an issue with Repetier.

    EDIT:  The problem is my impatience I guess.  It heats the bed, then when the bed reaches temp, it heats the extruder.  I wasn't waiting long enough.  When I enter the temperatures manually, I am able to heat them both at the same time.  When the software does it, apparently it does it separately.
  • That can be changed. M109/M190 heat extrduder/bed with waiting while M104/M140 just set without waiting. So set both first and then use the 2 waiting versions and they heat in parallel. Can be set in start gcode normally.
Sign In or Register to comment.