Repetier Server Linux - Can not access additional folder located in /home/username/3D_Files

I am running an OpenMediaVault file server that handles all the data storage for my network.

One of the shared folder contains all my 3D files dating back to 2010, with some filles even dating back to 2003!

I am trying to add this folder to Repetier , I can manually type in the dir, can't auto select it though. When I browse to the dir in Repetier it is empty.

Is this a permission issue?  The files are owned by my user and group is users.

Does this folder need to be in a certain location?

With Windows the shared folder mapped to a drive was seen and accessed properly. But we all know Windows is sh-t regarding permissions versus *nix.


  • Server runs as repetierserver.repetierserver so either group or user must match or all users must have at least write permission (x for folders). In global settings->folders it only shows folders. Here you only define a root folder and assign it to a name. In gcode when you use the dropdown for import you see that and should be able to browse through files in case permissions match.
  • OK, the "repetierserver.repetierserver" was what I was missing.

    I can either chown the folders\files over to repetierserver or add repetierserver to my group.
  • Well the chowning or adding the group didn't work. So I figured I would just move the dir to the repetier server and rsync changes back over to the file server. Yeah kludgy but it sorta gave me the advantage of having a sort of back of my files in two places.

    However the files were stl not gcode, so it was a moot point, lol.
  • Plus you still need to import them into the server project structure.

    For permission problem it might also that one of the parent folders was not readable for repetierserver user.
Sign In or Register to comment.