Serious issues with my Repetier Pi

I've been using 0.92 on a Pi 4 for quite a while now and I noticed version 1.2 was out.  I decided to upgrade and had no issues with the initial install.  I did however start losing wifi after the install, which never happened on the older version.  I finally got an LCD screen for my pi and it said no wifi card found.  I rebooted and it came back.  This is a serious issue for me that just started after the update.

Not only the wifi but my web interface does not work as expected.  I started having major issues with layers looking horrible so I thought something happened to my printer.  Slicer settings never changed and EEPROM settings never changed.  I went to recalibrate my extruder steps and told it to extrude 100mm from the web interface but it only extruded 45mm.  I recalibrated my extruder using the web interface but when I went to print is was over extruding twice what it was supposed to extrude.  I set the steps/mm back and it prints ok again but layers look horrible.  The touch LCD on the Pi extrudes 100mm fine while the web site does not and now I cannot even move the different axis via the web.  The Pi web version has become very unstable.  The only thing that has changed is the repetier server version on my Pi.

Any help or advice would be great.


  • The 100mm extrude is in deed broken and will be fixed in 1.2.1. Limit is 50mm for a single move command. 

    Did the wifi work after the reboot? Since you upgraded from very old image it might have changed the wifi management system. So question is if it now again works stable.

    I'm a bit overwhelmed by the mix of issues in one block with you telling you did change this and that especially since it was based on wrong extrusion I guess.

    We actually just send gcode 1:1 to printer. You might have a look at "Printer Setup" if you have set some temperature offsets. That might have an impact if they are not 0 so they modify your printing temperature which can be seen often. Also maybe check printer configuration especially first and second tab. There changed a lot so just in case the upgrade added bad values, also not really expected. But in rare cases it seemed to happen and here a lot changed after 0.92.

    After that check if it works ok. And if it still looks bad check and report what exactly " but layers look horrible" means? It is too general to say it depends on this or that. Same files should be printed the same especially if you have no communication errors with timeouts.

  • Thanks for the update.  WiFi has gone out twice this week.  Once the day of the update, after I started a 30 hour print, then again on Thursday.  Both times a reboot fixed it, but this never happened on 0.92.

    The bad layers may have been a partial clogged nozzle.  I had just finished printing something for my wife using a glittery filament before upgrading my Pi.  I am wondering if the "glitter" caused a partial clog.  You gotta love it when something goes wrong right before an upgrade but you didn't know so you think it was the upgrade that did it.  I ended up printing from an SD card and the print looks identical to the Repetier Pi print.  I swapped to an all metal hot end and recalibrated everything and it seems to be doing much better.

    I will definitely check out the new settings and make sure everything is good.  I understand things can change a lot with such a big jump in versions.  Looking forward to 1.2.2 getting the web interface fixed :)
  • These glitter filaments can really be a problem if you have small nozzle diameter. If there are some parts bigger or close to nozzle diameter you can get problems easily.

    If you continue to have problems with wifi consider using a new image on next update. You can copy all settings as backup with Repetier-Server Monitor. That way you get new linux, newer chrome etc. as well. But wifi was always a bit of a problem with pi - always quite sensitive. One reasons we switched to the original way raspbian uses wifi configuration on later images (not with networks manager any more).
  • I'm using a 0.4mm nozzle.  After replacing parts and recalibrating everything it seems to be back on track.  

    I did have issues with wifi before but stopped using 5G and went back to my regular wifi and it worked fine.  If I keep having issues I will start with a fresh image once you update to the next version.

    On a bright side, the LCD interface is awesome!  It's the first time I've used a Pi LCD.  Very pleased with that.  Thanks for everything!
Sign In or Register to comment.