Drucker stockt ca. 30 Sek auf einer Stelle

Guten Morgen, 
Ich habe aktuell ein kleines Problem beim Drucken über USB mit einem Prusa MK3S.
Es ist die aktuellste RepetierServer Pro Version installiert auf einem Rasperry Pi 4.

Und zwar habe ich beobachtet, dass der Drucker alle paar Layer mal einfach so 30 Sekunden stehen bleibt wo er war ohne Erkennbaren Grund, also direkt auf dem Objekt und drückt so natürlich einen fetten Klecks in das Objekt.

Im Anhang sind die aktuellen Verbindungseinstellungen, beim Überfliegen der Konsole erkenne ich auch nicht warum.
Ich habe auch mal Ping-Pong und auch 3 Sekunden Timeout probiert, und jetzt wieder auf 30 Sekunden. Das Problem bleibt leider.
Auf dem Prusa Mini funktioniert Ping-Pong ohne Probleme soweit.

Auch sagt er jedes Mal, dass das Objekt nicht reinpasst, liegt aber eher am Slicer, oder? Denn die Angaben für die Begrenzung passen eigentlich.

VG

Comments

  • edited October 20
    Hier mal ein geloggter Druck. Da gab es aber nur einen Timeout, dafür ein paar von diesen:
    Error:Line Number is not Last Line Number+1, Last Line: 159305
    Fehlern.

    https://imgur.com/a/iGrmYPD
    Das sind jetzt die Einstellungen, habe den Drucker einmal komplett entfernt und neu hinzugefügt.
    An dem PI sind auch keine Zusatzgeräte wie Kamera o.Ä. angeschlossen. Stabiles Netzteil.

    Der Log ist leider viel zu lang für Pastebin, und ich kann hier im Forum nix hochladen.
  • Timeout hast du wie ich sehe schon von 30 auf 3 reduziert. Ist beim Prusa auch kein Problem da er Busy Protokoll unterstützt.

    Hab mal einen von den Zeilenfehlen rausgesucht:
    Send:14:52:28.708: N135232 G1 X116.308 Y84.245 F10800.000
    Send:14:52:28.709: N135233 M204 S800
    Recv:14:52:28.720: ok
    Send:14:52:28.721: N135234 G1 F1500.000
    Recv:14:52:28.733: Error:Line Number is not Last Line Number+1, Last Line: 135232
    Recv:14:52:28.733: Resend: 135233
    Recv:14:52:28.735: Ignore due to resend: ok
    Recv:14:52:28.751: Waiting for resend requests finished. Starting resends ...
    Send:14:52:28.751: Resend: N135233 M204 S800
    Recv:14:52:28.757: ok
    Send:14:52:28.757: Resend: N135234 G1 F1500.000
    Send:14:52:28.758: N135235 G1 X105.416 Y77.219 E0.43875
    Recv:14:52:28.765: ok
    Send:14:52:28.766: M117 ETE 03:27:41
    Send:14:52:28.766: N135236 G1 X105.783 Y76.594 E0.02452
    Recv:14:52:28.774: ok
    Recv:14:52:28.774: LCD status changed
    Recv:14:52:28.774: ok
    Send:14:52:28.774: N135237 G1 X107.673 Y77.406 E0.06963
    Recv:14:52:28.782: ok
    Send:14:52:28.782: N135238 G1 X108.891 Y77.993 E0.04576

    Wie man sieht wurde er innerhalb von 20ms korrigiert, also keine 30 Sekunden pause hier. Auf der andere Kommunikationsfehler wurde so schnell korrigiert, also in diesen paar stunden sind keine Pausen durch Kommunikation entstanden.

    Vorher hattest du 11 timeouts, da sehe ich ein das er 30 Sekunden gewartet hat. Sollte es also weiterhin passieren bei aktivem log sofort die Uhrzeit aufschreiben und log +/- 2 minuten ansehen wo da die Lücke ist, dann sollte es klar sein.

    Das mit dem nicht im Druckraum passen ist korrekt. Wie du an der Meldung siehst druckt er bis y -3 (das ist die prime Spur aus dem start gcode) aber du sagt das Bett fängt bei Y=0 an. Ändere das und die Meldung ist weg.
  • edited October 21
    Repetier said:
    Timeout hast du wie ich sehe schon von 30 auf 3 reduziert. Ist beim Prusa auch kein Problem da er Busy Protokoll unterstützt.
    Genau, durch das erneute hinzufügen passt es jetzt.
    Ich habe auch die Bettbegrenzung auf -3 gestellt, dann kommt die Meldung nicht mehr.
    Bin vorher gar nicht auf die Idee gekommen, dass die Purge Line wirklich nicht im Druckbett liegt, und die Fehlermeldung ja korrekt ist.

    Mir ist jetzt auch erstmal kein Fehler beim Drucken aufgefallen, es funktioniert jetzt tadellos, er zeigt zwar bei den Verbindungsdaten vllt mal einen Timeout an, aber der wird ja sehr schnell korrigiert, nix was sich im Druckbett wiederspiegelt.

    Von daher danke dir für die Antwort :)
Sign In or Register to comment.