Image installation on RPi 1 B - WiFi not working

Hello everyone I'm trying to install the latest Server image on an old Raspberry Pi 1 Model B.

Following the instruction on the installation went well but I'm actually unable to connect the WiFi. I tried to setting up the WiFi connection from the web interface: I can see all the APs and select the one I want to connect to, I can establish the connection for a short time but in less than 10 seconds it disconnects automatically.

I tried also to manually override the connection adding the wpa_supplicant_wlan0.config file with the right settings paying attention to use a correct code editor such Atom but the results are always the same.

Until now I was using the same Raspberry Pi and WiFi USB adapter for the Repetier Server version installed on Raspberry Pi OS and everything worked fine.
I don't know what to do. Any suggestions?

Thank you.


  • Pi 1 has no wifi so it depend son the stick you have. Some can not scan network and be connected same time. See in the /boot folder there is a sample config for wpa supplicant. Enter your network credentials and and rename it to wpa_supplicant-wlan0.conf and reboot. Then server does not handle wifi at all and the config is set for wifi more or less the same as Raspbian does. That should normally work as then it depends to 100% on linux wifi handling.
  • I already tried to use the wpa_supplicant-wlan0.conf file with the same credentials that worked on Raspbian. It doesn't work. 

    I also changed the power supply with one more powerful without any improvement.

    If it can be helpful this is the iwconfig output when the WiFi is connected for a short time:
    lo        no wireless extensions.
    eth0      no wireless extensions.
    wlan0     IEEE 802.11  ESSID:"TP-LINK_764F"  
              Mode:Managed  Frequency:2.432 GHz  Access Point: 18:D6:C7:57:76:4F   
              Bit Rate=1 Mb/s   Tx-Power=20 dBm   
              Retry short limit:7   RTS thr:off   Fragment thr:off
              Power Management:off
              Link Quality=55/70  Signal level=-55 dBm  
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:0  Invalid misc:0   Missed beacon:0
    and this the ifconfig output:
    eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
            inet  netmask  broadcast
            inet6 fe80::ba27:ebff:feb1:1a32  prefixlen 64  scopeid 0x20<link>
            ether b8:27:eb:b1:1a:32  txqueuelen 1000  (Ethernet)
            RX packets 3397  bytes 384453 (375.4 KiB)
            RX errors 0  dropped 0  overruns 0  frame 0
            TX packets 1831  bytes 760189 (742.3 KiB)
            TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
    lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
            inet  netmask
            inet6 ::1  prefixlen 128  scopeid 0x10<host>
            loop  txqueuelen 1000  (Local Loopback)
            RX packets 0  bytes 0 (0.0 B )
            RX errors 0  dropped 0  overruns 0  frame 0
            TX packets 0  bytes 0 (0.0 B )
            TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
    wlan0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
            inet6 fe80::22e2:16ff:fe00:52ed  prefixlen 64  scopeid 0x20<link>
            ether 20:e2:16:00:52:ed  txqueuelen 1000  (Ethernet)
            RX packets 944  bytes 150647 (147.1 KiB)
            RX errors 0  dropped 0  overruns 0  frame 0
            TX packets 1896  bytes 273536 (267.1 KiB)
            TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

    I don't understand much: it seems that the wlan0 interface doesn't have any associated IPv4 but in my router's device list it appears with the static IPv4 I just previously assigned.

    Thank you.

  • Agree, it shows that it is connected with TP-LINK_764F which is your router I assume.

    Do you assign it the ip via dhcp? That is the assumed default normally. All you normally do on the route ris assign your wifis mac address 20:e2:16:00:52:ed the ip you want. Note that mac might be different to the one on Raspbian before - we use the hardware mac I think and no virtual one.

    You should have a look at /var/log/syslog where linux logs the wifi attempts to connect. Maybe you see why it fails, e.g. wrong password.

    wpa_supplicant-wlan0.conf is in /boot folder? I ask because we copy that file to /etc/wpa_supplicant overwriting old one. Eventually you need to reboot to make linux see new version.
Sign In or Register to comment.