Offset temp doesn't work

Before upgrade to 1.1.0 extruder offset temp doesn't work. (I don't try heat bed offset setting)

I try to rewrite values for each printer but this doesn't solve the problem.


Comments

  • What are you trying to solve?

    Offsets get only applied to the print and not when you send them manually, so maybe you are expecting this. But it is meant to equalize behaviour on gcodes while in front end setting temperatures is just what it is. So offset 10 make setting it to 200 in gui set it to 200.
    M104 S200
    in printed gcode will send instead
    M104 S210

  • I don't talk about manual tuning.

    When you first implemented the function it worked great.

    After the updates it stopped working. Please check it out.

    Here a example when this works:



  • Sorry but you say in 1.1.0 it works and complain that it does not work for same version. Your working example is 1.1.0 and it hasn't changed in 1.1.1 and 1.1.2. So what case is not working when you show latest version and say here it was working. As I already said in g-code printed it is used in manual code send not and that is intentional and was always the same.
  • edited September 1
    Now I'm in the lastest version 1.1.2 and this does not work. Please check that with your fresh install.

    In 1.1.0 this works only in one printer of the server.

    I will make a youtube video showing that.
  • I retested it and it still works correct for me. So please also show your settings and gcode and result on print when you make the video. Currently I think it is more likely that config is not as you expect. Best is also to provide printer xml and sample gcode for testing in case the problem is in the settings.
  • I tink I found what is the problem.
    Console log:

    Send:23:39:07.074: N13 M140 S60
    Send:23:39:07.074: N15 M190 S60
    Send:23:39:07.074: N16 M104 S205
    Send:23:39:07.075: N18 M109 S195.000000
    Send:23:39:07.081: N19 M82 ;absolute extrusion mode
    Send:23:41:46.928: M117 ETA 00:54:36 day 3
    Send:23:41:50.778: M117 ETE 01:15:26
    Send:23:42:00.771: M117 Layer 0/378

    Perhaps it is necessary to also update the value of M109
    GCODE:
    M140 S60
    M105
    M190 S60
    M104 S195
    M105
    M109 S195
    M82 ;absolute extrusion mode

    Ofsett +10 Extruder 1

    Please look at the strange behavior that happens on the two printers.

    The first time in v1 it works fine.
    The second time in v1 does not update M104 or M109
    The first time in v2 M104 does not work and M109 works.







  • Thanks for the data. I could reproduce it. The result is just random depending on a flag if s is integer or not that was not initialized. Will be fixed in next update.
Sign In or Register to comment.