Printer Nozzle Frequently Crashes into Bed

For the last few months my printer has been crashing into the bed quite frequently. It seems to happen often when I first boot the printer. I'll turn the printer on and send a command to move the nozzle upwards away from the bed but instead it will move down and crash straight into the bed. It also frequently happens immediately following an autolevel. I have customized the auto leveling in the firmware though, as I've discussed here before, so I could have made a mistake there. It also happens mid autolevel sometimes. Earlier today I ran an autolevel, and after probing 3 corners of the bed it went to probe the final corner and crashed. Any ideas why this could be happening? I'm afraid to try out our new glass bed because of these frequent crashes.


  • Are you homing to z max? The first move should always be a homing command - otherwise if your firmware thinks e.g. you are at z=200 and you send G1 Z100 while you see it is at bottom that means for printer move down 100mm! Here also server moves are affected. You see the coordinates we assume and next move is based on what you see as coordinates. Just because when enabling the position is unknown and firmware is probably not assuming the same position. Check if you can prevent moves while unhomed to prevent any false moves.

    Crashes during autolevel are more a firmware issue - most likely not correct configured. But that depends on firmware, what printer type you have and config. So nothing where you can directly say oh that is the crash bug, disable that switch:-)
  • The first move is always the homing action and it's during that homing action that it will crash because it will move the wrong direction. For Z-Min we have an inductive sensor on our carriage and Z-Max we have yet to implement since last time we tried the printer refused to run until we unplugged our Z-Max limit switch.
  • If you look into the console you see that server just sends G28 - execution lies on firmware side, so that is more a firmware than a server issue and needs to be fixed in firmware configuration.
  • It could be a signal problem. Do you have long cables to the steppers?
Sign In or Register to comment.