Force RS to use right frontend template

edited April 25 in Questions & Answers
Good Morning,
I am using Repetier-Server 1.0.4 Pro on a Raspberry Pi 3B+ with a Faytech 7" Touchscreen.
I have the following issue:
If am booting the Pi from cold the frontend starts always with the resolution of 640 x 480 px
xrandr shows:
pi@Ender3Pro:~ $ export DISPLAY=:0
pi@Ender3Pro:~ $ xrandr
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 640 x 480, current 640 x 480, maximum 640 x 480
default connected 640x480+0+0 0mm x 0mm

Rebooting it without turning the power off (via ssh access) the resolution is:

pi@Ender3Pro:~ $ xrandr
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 1184 x 624, current 1184 x 624, maximum 1184 x 624
default connected 1184x624+0+0 0mm x 0mm
   1184x624       0.00*

The touchscreen interface is right now (7 icons in a line with the main bar on the left side)    
   
This resolution is the one I used to calibrate my touchscreen and I want to use this one.

I tried to force the pi to adjust this resolution by adding framebuffer_width and _height in /boot/config.txt but as a result, the resolution of the screen is right adjusted but the frontend is stretched in x-direction now and I have black borders on the top and bottom. Adding overscan does not help either.

Any suggestions?
How can I force the pi to use the desired resolution and force repetier server to use the right frontend template?

Regards
Stefan

Comments

  • Repetier adjust automatically to size available using media queries inside css. I guess the problem is the display does not send right informations at cold start so it uses wrong settings. 1184x624 is not the correct resolution I think. Never seen that and it is no standard resolution. Also I can not say what you must set the display data correct in config.txt. See
    https://www.raspberrypi.org/documentation/configuration/config-txt/video.md
    for possible options or check internet for your display. When you explicitly set it I think it starts cold also with right settings.
  • Repetier said:
    1184x624 is not the correct resolution I think.
    This is what xrandr said. Anyway this resolution works for me after reboot. I did not adjust it explicitly, It came out during Repetier server installation.
    Repetier said:
    I will check that of course.
    Repetier said:
    When you explicitly set it I think it starts cold also with right settings.
    If I explicitly set it in config.txt, xrandr gives me this values back so I think the values are taken right  and the same as after reboot.
    But Repetier-Server frontend uses a different template then, for what reason ever.
    I will check the settings for the Faytech in the Internet on a Pi. Display was popular in former times, so there should be some information regarding this perhaps. The native resolution of that display is 1024x600 px (17:10).
    Thanks for your help Repetier!
    Regards
    Stefan
  • Server uses always fullscreen as far as I can say. Only difference between sizes is if you see more on top bar or font/icon sizes which depend a bit on resolution. But with wrong timings the screen might not show on full screen or look wrong. I have e.g. one display lat looks stretched without correct config settings because it puts 600 height in 480 pixel.
  • Thanks for your efforts Repetier!
    I found the solution by modifying config.txt:
    hdmi_group=1
    hdmi_mode=4

    Now the interface starts with 720p as I want it to.
    Regards
    Stefan



Sign In or Register to comment.