Temperature display in the interface bugged?


i have the 0.60.3 server on a pi b+ running, 2 printers connected and everything works really fine, thanks for this nice piece of software.

but im here because of the temperature gauge/graph in the web interface. which has stopped to work after i connected the 2nd printer.
i mean not the chart, its the display in numbers in the "extruders" section of the "control" interface, where you can see the heat bed and the extruders temperature... both heat up normaly and the print does work but it shows the room temperature and not the temp of the hotend or the bed.
it seems to be frozen, but the graph / chart below displays the right temperature and works as intended.

disconnecting the 2nd printer does not help, rebooting not also.

its not a big issue but seems to be a bug.


  • I will check that. What about the extruder temperatures in the right side on move control tab, do they update correctly for you? I just tested it quickly with one printer and it worked. I guess if you open development console in browser and then check console you will see and error there. In that case please send me the configurations of the two printer, so that I can examine why that error occurs. I guess an error stopped printer status polling so the current values get no more updates adn these contains temperatures. 
  • edited June 2015
    no the temperature numbers in the right lower corner do the same... is frozen. 
    the only realtime temp display wich works is the chart. 

    i tested it with marlin and repetier firmware and on every other software it works. the problem only occurs on the webinterface of the server.

    the 1st printer is a prusa i2, its 3 years old and i don´t have the firmware any more. is there a way to download the firmware from the printer? it runs marlin 1.0.0

    the 2nd printer is a smartrap, wich has problems with its autolevel probe. i can´t figure out why it does not work and im struggling with it for days now.

    the probe is the hotend it self and after probing with G32 S2 it probes its first measure point and stops there and says
    Z -2.x X 0.0 Y 0.0

    before i hit this problem (i don´t know why it does not probe the other 2 points) i got it somehow to measure the 3 points and to start the print but it always printed 2mm to high on the Z axis, the hotend was 2 mm in the air over the bed while the Z axis was moving during the print. 

    after hours of testing and playing with the firmware i gave up and went to sleep... the next day (today) it does not complete the 3 point measurement and i don´t understand why or which setting i have to change to get it to work
    (it simply ignores settings like Z_PROBE_BED_DISTANCE and Z_PROBE_HEIGHT) i tried to overwrite the eeprom with M500 and the "1 or 2" value in the firmware itself, no effect.

    i opened a new thread for the autolevel issue: http://forum.repetier.com/discussion/884/a-lot-of-autolevel-issues

  • Firmware is not relevant for temperature bug. As you see right temperatures the server reads out them correct.

    What I would need is the server configuration. In home screen you can download them as xml files. My guess is that something there causes the browser to create a error stopping update loop.

    Which browser are you using btw?

  • edited June 2015
    i use chrome.

    now i figured out what the problem is... its not really a bug, i think.

    the 1st printer, stays connected to the server (pi b+) all the time and is online, while i have the 2nd disconnected to upload new firmware from a PC.

    when i disconnect the 2nd printer, the pi seems to disable its port /dev/ttyACM0 and then it changes the ACM1 port to 0.
    this leads to shift the two printers added in the interface. it thinks the prusa i2 is the smartrap.

    so it shows the (in reality) online printer, which is still connected, as offline and shows the physical offline printer as online, because of the ports.

    i simply switched the ports in the webinterface, now it works as intended, even i disconnect a printer.

    so... it looks like:
    if /dev/ttyACM0 gets disconnected, /dev/ttyACM1 becomes /dev/ttyACM0 and this messes everythin up i guess.

    thank you for your great (and fast support).

  • You should really not use these ports on the pi. The server suggests first ports like /dev/by-serial - these are identical with the big exception that the name differs by printer just like windows would assign always the same COM port. Using these solves the who comes first problem and gives you the security that you are talking with the right printer.
  • yes, i changed them now to the sugested ports. 

    thank you
  • This could be related to the problem I'm still seeing with Rep-Host losing the Bed temperature display.  I think there is a correlation: this line appears when Rep-Server is running, but does not show up when Server is not running.  The Bed display appears when print is started, but I must set bed temp manually on the display / firmware.
Sign In or Register to comment.