no way to get "pdf reports"

Repetier-Server 1.0.4 on PI

i enable in printer configuration below firmware settings - "Log all Printe in a History Database".
i enable in global settings->Print Reports "keep reports of last year"
i enable webcam snapshot to report
i applay

I make a new print

at the end of the print go in history but i don't see a new pdf button to view the report.

connect via ssh and in "/ var / lib / Repetier-Server / reports" there are no pdf reports.

i make a new fresh installation on new sd.
i try all variants "do not delete reports"/"keep last 500 reports"/"keep reports of last year"
i try enable/disable webcam snapshot.

the result is always the same no pdf report is generated.

Where am I doing wrong?

thank you


  • Do you get the regular history entry? For this you need to enable for the printer "Log all print to a history database". Only if that is enabled the global pdf report setting will be applied.
    PDFs will only created for new successful prints in that case. 
    Does creating snapshots work? I recently detected that when webcam was not available the creation of pdfs failed. Should be fixed in 1.0.4. In my test installation it is working that way. Here I have set to keep last 500 reports. Keep last year might be a problem on pi where the clock is reset after restart until it reaches a time server.
  • yes for each print there is an entry with various information: 
    "start end", "printer user", "file status", "duration real / duration computed",  "filament used cost", "notes" 
    and at the end two icons "edit" "delete".
    A new entry is regularly added for every print I do.

    yes under printer setting->general->firmware 
    i have enabled "log all printers in a history database".

    I make a new print which ends successfully, 
    its entry is in History with all the right fields but not the pdf icon.

    yes snapshots and recorded videos work fine

    I tried now with a print, i setting "keep last 500 reports" 
    and enabling "add webcam snapshot report" but at the end of the print 
    i got the entry for this print in History but not the pdf icon.

    I repeated everything disabling "add webcam snapshot report" but in the end no pdf.

    I first tried to delete all the entries in the history, 
    i make a new print, his entry appears in the History but not the pdf icon.

    I do a fresh install on the new sd card. 
    I configure everything the same i do a print but no pdf.

    My Hardware:
    one "Raspberry Pi 3 Model B"
    one "Raspberry Pi Camera Module v2"
    one "Raspberry Pi Touch Display" (original 7").
    one "samsung micro sd 32gb"
    one "creality CR-10s printer"
  • News!
    It's my fault. I did not specify that I was evaluating the product, it was not yet registered.
    I bought the software and after entering my "license key" everything works perfectly.

    Just out of curiosity it is possible to know how many installations are left of the 5

    I'm sorry
    thank you!
  • Good it works. Did not think of it being pro feature.

    No currently you can't see how much are left. But if you get message that all are used up and you have less installations just drop us a message and we reset it. But if you always deactivate before deleting a installation you get the count back on your own.
Sign In or Register to comment.