Resetting Home position

I have looked and can't find this question so here goes.  I have a Geeetech I3 Pro B and am having issues getting my X axis to home.  I click auto home and it will move to the right just a touch then stops.  It should go left to the endstop but doesn't.  Also when I look at the M119 it says the endstop is triggered and it isn't.  Any help please?


  • Not a host problem. Is the end stop switch maybe defect? M119 should report L/off when not triggered and H/on when triggered. Without this move toward x min will be prevented as you see in homing, except it is only tested during homing. If it is a closing end stop unplugging should make it low. Homing might work the but will crash into the side since no end stop stops it. Or it will detect missing end stop and block firmware.
  • Yes, we tried unplugging it and checking with a multimeter and the switch seems to be working correctly.  I am thinking I'll order one just to be sure.  When I run the M119 it always says it's triggered even when it isn't which had me thinking it is a problem in the coding somewhere since electrical wise it seems to be working.  Thanks for the reply.  Didn't think it was a problem with Repetier just trying to find some help. 
  • Maybe firmware has configured a different pin for that end stop. After all many boards have 6 headers for end stops while only using 3-4. Or the pin is defect - in that case you could configure the firmware to use another pin instead. At least if you have the sources available.
Sign In or Register to comment.