Raspberry Pi Server No Boot

Good morning,

Looking for some input.  I just re-imaged my rPi with latest build of Server.  However, it does not seem to boot up past a splash screen (just Repetier Logo seen over HDMI out).   I see the device join the wired network (i.e. it seems to be given an IP address), but I cannot seem to connect to it in anyway (Putty, ping, etc).   It does not respond to the connection via web browser either.  Not even thru the IP.   I have tried with and without a wired network connected, with and without HDI connected, with and without the wireless dongle connected, with original SD (16GB) and a new SD (64GB), repeated re-imaging on each card.

At one point I was able to connect to the IP address, but all I was able to get was a screen that said Repetier server was not running and it was going to retry.  which it did every 20-30 seconds or so.   For a long time it tried.    It also had a suggestion to restart via command line, but it did not work ( that time I was able to Putty in, but that in no longer the case even after reimaging. )     

For what it is worth, I had an image on this Pi prior that was working and feeding a delta printer just fine.  That Printer has Repetier firmware, but is mostly retired.   That image had issues with my Ender printers power cycling whenever connected to the Pi, so I tried the trick of a small piece of electrical tape over the +5v pin on the USB cable to the printer, but it did not work and I think made things worse.  if the current issue is any indication.    

It is an older Pi (Model 2B, maybe.  I am not sure how to read the label on the Pi.  It say Model B, v2).   Any suggestions on changes to config files for my older Pi?  Or is there a better build version of Server that is known to run with an older Pi better?  I do not recal what the old install was.

Thanks to all who may have some insights.   



  • Tested it. First time I did not see it appear and also pi 3 and 4 did not work any more:-( Reflashed with latest 1.0.3 and then pi 3 and pi 2 worked like expected.

    Then I checked md5 sum:
    MD5 (Repetier-Server-Image_1_0_3_v24.zip) = a77c1a3bc8dc33f9517be3f46bb7cf19

    Please check your image if the md5 sum is correct to be sure the image is correct.

    First start takes a bit longer since image will expand the filesystem so do not hurry or it may break if you unpower too early. But should not be more than a minute. It is quite fast. Try first without printers connected so you have no power problems or anything else disturbing on bootup. We all know how sensitive linux/pi is with voltage drops.
  • Thanks for the feedback.  I checked the md5 sum and it was correct.   I believe it is a hardware compatibility with the latest version or a true hardware issue.   I was able to locate the image for the previous version I had installed.  The file name was Repetier-Server-Image_0_91_2_v14.   I re-imaged with that version and it initially worked as expected.  Although I had to pull out the WiFi dongle to get our wifi to show.   But that could have been something else.  After a short period it lost the wifi again, and could not get it back.   It is stuck in access point mode, and I can no longer gain access.   I believe the issue is that the hardware is not functioning correctly.   I will try a new Pi or dongle at some point in the future.  Thanks again.

Sign In or Register to comment.