Stuck at preparing print.

Was working fine before i had to cut the power abruptly now it gets stuck at preparing print. It pops up for a bit then goes away.


  • Cutting power can corrupt files. Especially the data bases might get corrupted more easily. First check the server.log file in logs dir of storage directory. Also check in development console of the browser if you see any errors that could give a hint about what fails.

    You could simply reinstall to make sure binaries are ok and if it still not works try disabling -> rename database for testing -> start again. Will start with new database created. If it was not the database you can restore old database after stopping server again.
  • At the moment i'm stuck at trying to figure out how to uninstall. I know how to reinstall just not take it off. I'm too new with the raspberry pi and am like a lost child. I can navigate to the downloads folder in the terminal. But i don't even know where it installs or what to look for. I tried sudo apt-get update but nothing looks close to what i'm looking for.
  • Install is all you need. Just do a 

    sudo dpk -i debfile

    that will replace all executables. All remaining files that do not get changed are at /var/lib/RepetierServer so in worst case you delete this directory and have a fresh installation after starting with
    sudo /etc/init.d/RepetierServer start

    (or restart/stop depending on what you need)
  • also for some reason when i type /etc/init.d/RepetierServer stop in a terminal it says it stopped the server. But when i try to connect it still works. Since i picked up this raspberry pi just for this server another possible option is to reinstall the OS from scratch and start over. Ill try that and post an update.
  • Fixed the problem reinstalling the OS on the PI.
  • Might have got some corruption when it was origally installed. Good hear that it is working now :)
Sign In or Register to comment.