Touch screen stopped responding

So after just getting a trial version up and running, touch screen working during the entire setup, after adding printers and configuring everything in my browser, the touch screen no longer responds. It's on, I can see it, but can't use it. I have a rpi 4b attached to a 7" touchscreen. Is there a step I've missed? It's not making sense to me because it was working. All in about a one hour span. Sorry if my description is too vague, but I don't know how else to explain it.

Comments

  • To further investigate I would change in /boot/repetier-image-setup.txt the HIDE_MOUSE to 0 so you see the pointer from linux. It moves to where you touch. Then you see if it just misses the point you point or does not react at all.

    It can also be a defect. I had already one original touch screen where suddenly the upper half did not work any more. Especially if it worked and you did not change touch calibration that is a possible reason.

    With mouse not hidden you can also connect a real mouse to control the interface. But touch is of course better since we optimized it for this.
  • edited January 7
    So yesterday, I reflashed, started over, and again, it seemed to be working. Today I start it up, and again, no touch. I disconnect the printer USB cable, and then it works again. What could cause this? I believe this to be the issue. Something in the usb connections. Could it be that my touch interface is connected from the touchscreen's board to the pi's usb? Is there another method of connecting?
  • Ok, so it is not the original display with touch but some other and extra controller over usb.

    Does this require some extra module being loaded? Or does it work out of the box?
    lsusb
    on ssh connection will show list of connected usb devices. Find out which is your display then you see if it is still recogniced. You can also check /var/log/syslog - there linux logs all important messages. So if it does change touch handling I'm quite sure you will find a message about that there.

    The gui has a bolt icon where you see if you had undervoltage. During undervoltage linux disconnects usb devices so that can in deed be the case. You could close the 5v line in printer usb cable so printer will not draw current from the pi, see here:
    https://www.repetier-server.com/knowledgebase/undervoltage-and-throtteling-of-pi/
  • Thank you. Will try all this today. I believe your suggestions may lead to a solution! I will report back later tonight! I do have an appropriate power supply but I believe the printer trying to draw power from the port is the problem now.
  • Ok, I did tape up the 5v power pin on the usb cable, but still getting the same result. If the printer is plugged into the pi when it boots, touch will not work.  I've looked at that log, but I don't really know what to look for to know. What should I look at? Thanks for all your help.
  • in order to help it would be useful to know exactly what Type of Display you have
  • Not sure of the actual brand name. Possibly Lebula? It's a 7" and worked out of the box without installing drivers. And as mentioned, continues to work as long as my printer isn't plugged into the pi.
  • Does it stop working when you plug in printer later? If so run
    tail -f /var/log/syslog
    and plug in the printer. Then I would expect the important part in the log that appears then. Hit Ctrl+C to stop logging.
Sign In or Register to comment.