Repetier server not reconecting

Hi.
I have installed Rpetier Server on raspberry pi. Made 2 printer (both with MKS Robin E3D board). Everything working great, but only for the first time (just after I add the printer). When I turn off any printer, or just push ESTOP in Repetiet it's showing as connected but no communication. Server trying to get communication, but can't. To make it working once again I need delete printer, once again make a new one (or just upload config file) and it's working. But only till I turn off/reset the printer. I'm using Marlin 2.0.7.2
Is there anything I can change to make it working constantly?

Comments

  • Try changing dtr/rts setting. Some boards are sensitive to this and refuse communication. Guess is that after adding it the settings were ok and after reconnect the "wrong" value kicked in. If that is the case please test what it says during wizard, what it stored and what worked for you. I have no boards with that problem just now it exists. So it might be that something goes wrong without me noticing it.
  • edited January 5
    OK, so when wizard is running Repetier detecting DTR/RTS Low to high and buffer size 63. In printer setting is same DTR/RTS but different buffer size (127). I'm changing it manualy to 63, but still have problem with connection. When i change to DTR/RTS to low it's going to connect but not immediately - need to wait few minutes.

    But if i remove printer and upload config file communication starts almost in same time as i press "create" button. No matter what i have in DTR/RTS
  • Which server version are you using? 1.0.1 or older version? In older there was a bug in dtr/rts handling that might explain it. In general wizard and regular connect is the same function so should work same. You can also test if deactivate/activate makes it work faster. Taking a few minutes to connect is not correct also it can happen that you hang in a loop with bad luck. Then press reset button on printer if you have one there. That often breaks such loops.
  • Yes, I'm using newest one.
  • Ok, wizard is a bit buggy as it seems. In my tests it also did not copy the selected value if you preselect it. Will fix that for next update.

    The other thing is that first connection test is always run in ping-pong mode. So have you tried activating ping-pong for your printer? Does it connect better then?
Sign In or Register to comment.