Tronxy X5SA Pro: Update from 0.94.3 to 1.0.1 -> Printing doesn’t work anymore

I have had V0.94.3 on my Tronxy and printing via Repetier Server (on Raspberry PI4) was working fine.
After update to 1.0.1 unfortunately it doesn’t work anymore... means that printer doesn’t start to print after G29/G28... and waits and waits...
I should mention that I have uploaded Gcode from PC to PI4 Repetier server... and I have tried to print directly started from PC and also from Touchscreen menu... both times nothing really happens.

To exclude that the issue was related to the Gcode-file, I have printed it successfully from SD-card via Tronxy-Panel... there were no issues. So, I guess the issue is related to update to version 1.0.1, and I habe to go back to v0.94.3.

Does anybody have similar issues with new version 1.0.1?


  • Please check in console by sending some of the commands especially where you think the problem is if they work and communication with printer is fine. 1.0.x has new handling of G28/G29 to read the position reported. Worked great on my printers and I don't really think it interferes, but you never know. 

    Otherwise enable logging for prints and show the log where it fails so we can see what is happening.
  • Unfortunately, it is too late for checking the logs... I have downgraded to and be happy again... waiting for a new release.
    The issue looks like this one:
    He described nearly the same behavior after upgrade to 1.0.0...
  • Well his problem was fixed in 1.0.1 so if you had problems with 1.0.1 it is something different. And since I don't have a troxy printer I can not check my self. My printers all work fine. But maybe some other use will have same problem and report with more info.
  • Of course, let’s wait... in parallel, I have bought a SKR 1.4 Turbo Board and will upgrade my X5SA with it, and then I shouldn’t have problems anymore.  ;)
Sign In or Register to comment.