Connection speed in configuration

Wish you all merry christmas,

i´ve upgraded a printer and implemented a BTT SKR Pro V1.2 board and tried to replace the configuration in the repetier server on my RPi. It was really an exciting mission. 
i am used to configurate boards. Did in the last 6 months around 7 different brands and printers. All till now are working fine.
Ok, back to the topic.
I´ve all my 32 bit boards running on baudrates of 250k. This board was fighting against it. It received at the connecting point the ip adress but...repetier was not able to connect to it. The browser showed this connecting phase "yellow" and was reconnecting every few seconds. I´ve seen some feedback on the console, but it was always canceling the connection.
Good, i was like...could i get it connected? I´ve tried to do the "check several connections". It was showing me one connection successful, but it wasn´t working.
Now, because of the TFT which i connected to the mainboard i reduced the baudrate in Marlin to 115k. The board and display are working fine.
Now i´ve attached the usb to the RPi...all was from before set to 250k on the repetier server. 
It was and it still is connected and green. Switched the printer on and off...moved via the server the axis...yes, it´s connected stable.

But...on the connection settings it is still set to 250k. But, it is for sure not communicating on this baudrate. 

Could you maybe give me a hint? Was it the speed at first? Why it is not using the settings which are set up in the server? 


  • First are you on 1.0.1 server version? We hopefully improved connection there. Marlin does block anything when showing a splash screen which could cause a timeout closing connection if it took to long to send an expected response. Now we are more patient.

    Not sure if it is the same with that board but I have the SKR1.3 and there the board does not use a serial connection. It fakes serial but is direct usb to firmware. Which also means that the baud rate is complete irrelevant in that case. Any baud rate will result in same speed. If thats the same it explains why it works with different baud rates. It might be a problem with the linux driver when you signal a non ansi baud rate (250000 is not ansi specified). But that is hard to say since I did not write these drivers in linux.
  • Yes, I am on 1.0.1. and this 1769 chip is indeed a direct serial connection. Sometimes it's even getting little bit crazy and refusing some attempts to connect. But somehow now it's also running on 115k in RS and 250k on the chipset. I did modify some Marlin Buffer settings and still testing, like TX buffer Xon/xoff activated and increased the communication values little bit. Hope this will keep the display more calm with the messages which pop up,when RS reconnects. It's more like kind of mood of communication...if it's getting started more less synced to the other one...hope they will go back one day to standards, this few cents worth it.
  • With SKR1.3 buffer size did not matter at all. It just only accepts packages when it is ready to read as it seems. But Marlin had some issues with 2 parallel communication buffers in V2 and recently improved it as far as I can say. So maybe update marlin version to get the BTT TFT more calm.
Sign In or Register to comment.