I have had Repetier 2.1.6 and under manual controls it had a flow rate. Since then I have had to redownload Repetier and now it does not have a Flow rate under the manual control. I have uninstalled Repetier and reinstalled it completely but the Flow rate control under the manual control is still missing? Has this happened to anyone else and how did you fix it?


  • Disable easy mode and it reappears.
  • Thanks for your help that took care of it!
  • When I open EEPROM in Repetier it is Blank, I see the options at the bottom that will allow me to import it. I originally downloaded the Repetier firmware but I do not know why it is blank. Any help would be appreciated
  • Are you using repetier-server in addition? There was a version where eeprom query did not work so please in that case update to 1.0.3 where the problem is fixed.
  • If the repetier-server is when you have to connect to the internet to run then I am not. I am running V2.1.6. 
  • Server does not need to run on internet. Host offers installation during host installation on windows machine. YOu see it in host when the connector is named repetier connector.

    What does the log say when eeprom sends M205? Any response or a message eeprom not supported?
  • No I am not running Repetier-Server. I am using Serial connection. I tried Repetier Server and that is when Firmware EEPROM was not greyed out however I kept getting a connection break when I was printing so I went back to the Serial connection and that fixed that. Now the Firmware EEPROM is Greyed out. 
    When I ran M205 there is no errror it says OK and code or numbers after that.
  • Does M115 show a Cap: line with EEPROM:1 ? If it shows 0 it will not offer eeprom. There was a small time a bug in firmware returning the value wrong which caused eeprom to be grayed out in host.

    M205 should return around a 100 lines with values and strings you would see in eeprom editor.
  • When I Ran M115 the first time it appeared to have EEPROM with the 0 behind it, however it passed by really quickly as a bunch of code ran by. It was on auto scroll so I am thinking that is the reason. I ran it again and EEPROM never came up again so I could not confirm it. Not sure why. 
    If it does have a 0 behind it how to I change it? I will just go there and confirm unless you recommend otherwise.
  • It depends on how firmware was compiled. EEPROM_MODE 0 would have it 0 all other values like 1 or 2 would make it 1 and make it support eeprom. And make sure to use last firmware so you know the bug with wrong reporting i snot present.
  • So I Originally downloaded from the Repetier Site and downloaded the Firmware and set it up there. Now that it is downloaded where do you recommend I go to fix it? 
  • Just upload old config (if created with config tool) make sure eeprom mode is not zero and download, compile and install. That should fix it.
Sign In or Register to comment.