Issues after upgrading to V1

Hi Guys.
I'm having major issues on 2 raspberry pi server installations after upgrading to V1.0
I'm using in combination with the latest edition of server monitor. Adding a file to a printer's autoprint folder results in a job being added to the print queues with a time of NaNs - at this point the server web interface becomes unresponsive requiring a reboot to clear. Once rebooted, the job in the print queue has a valid time and can be printed. The same happens if I upload gcode to directly to the server (happening on all printers and both servers). If there is any job in the queue with the NaNs time, nothing can be printed. Either from a direct print, gcodes already on the server etc. It just gets stuck 'preparing print'.

Any suggestions before I resort to a complete re-install? (I'm having to print from SD cards at the moment!)


  • After many reboots, deleting the workdispatcher.sql file etc, I am able to print but only by uploading GCode directly. If I try anything using the monitored autoprint folders, I still get the NaNs time issue and associated lock up/crash which can only be cleared by stopping and re-starting the RepetierServer service or re-booting the pi (as mentioned, this then leaves a valid job in the print queue, with correct time). 
    I can work around this for the time being but the monitored folders have become part of my workflow so I could really do with assistance correcting this.
  • Yes, there is a dead lock in direct print function. Over gcode upload and print this does not happen. Will be fixed in 1.0.1 coming very soon as emergency update.
  • Cool - thanks :-)
  • Please fix the temperature update problem of ender3 series
  • As far as I know it is fixed, but I have no ender 3 printer for testing. During beta users said it works. I need a log with output of ender 3 if it still is not working to get more information on what is wrong. Important parts - does ender 3 autoreport temperatures or claim it (send M115 to see the cap). If not what is the M105 response.
  • Thanks for the V1.0.1 update - my monitored folders are now sweet again.
  • M115
    Recv:11:44:33.355: FIRMWARE_NAME:Marlin Creality 3D SOURCE_CODE_URL: PROTOCOL_VERSION:V1.0 MACHINE_TYPE:Ender-3 EXTRUDER_COUNT:1 UUID:cede2a2f-41a2-4748-9b12-c55c62f367ff
    Recv:11:44:33.357: Cap:SERIAL_XON_XOFF:0
    Recv:11:44:33.361: Cap:BINARY_FILE_TRANSFER:0
    Recv:11:44:33.361: Cap:EEPROM:1
    Recv:11:44:33.362: Cap:VOLUMETRIC:1
    Recv:11:44:33.366: Cap:AUTOREPORT_TEMP:1
    Recv:11:44:33.367: Cap:PROGRESS:0
    Recv:11:44:33.369: Cap:PRINT_JOB:1
    Recv:11:44:33.369: Cap:AUTOLEVEL:1
    Recv:11:44:33.371: Cap:Z_PROBE:1
    Recv:11:44:33.372: Cap:LEVELING_DATA:1
    Recv:11:44:33.374: Cap:BUILD_PERCENT:0
    Recv:11:44:33.377: Cap:SOFTWARE_POWER:0
    Recv:11:44:33.377: Cap:TOGGLE_LIGHTS:0
    Recv:11:44:33.379: Cap:CASE_LIGHT_BRIGHTNESS:0
    Recv:11:44:33.382: Cap:EMERGENCY_PARSER:0
    Recv:11:44:33.385: Cap:PROMPT_SUPPORT:0
    Recv:11:44:33.389: Cap:AUTOREPORT_SD_STATUS:0
    Recv:11:44:33.389: Cap:THERMAL_PROTECTION:1
    Recv:11:44:33.391: Cap:MOTION_MODES:0
    Recv:11:44:33.394: Cap:CHAMBER_TEMPERATURE:0
    @::00 BB@@::00
  • edited December 2020

    @::00 BB@@::00
    @::00 BB@@::00
    @::00 BB@@::00
    @::00 BB@@::00
    @::00 BB@@::00
    @::00 BB@@::00
    @::00 BB@@::00
    @::00 BB@@::00
    @::00 BB@@::00 (2)
    @::00 BB@@::00 (2)
    @::00 BB@@::00
    @::00 BB@@::00
    @::00 BB@@::00 (2)
    @::00 BB@@::00
  • This is the heating state

  • I had fixed the problem but somehow that code part was not included any more. So 1.0.1 is still not able to read the defect firmware output. Will be readded in 1.0.2. Until then just use it and don't trust shown temperature. Update will appear in a week or 2 I guess when I'm through with all reported problems I could reproduce.
  • Thank you very much and look forward to it
Sign In or Register to comment.