Verbindungsproblem über Web Interface

Hallo Forum,
ich hab ein kleines Problem

ich habe an meinem Pi einen 7" Display hängen
Auf dem Pi ist Raspian installiert und der RS.
Der Grund ist da mein Drucker im Keller steht und ich Ihn oft über den kleinen Monitor starte.
Dieses mache ich immer über die normale Weboberfläche.
Seit längerer Zeit hab ich aber ein nerviges Problem.
Ich erreiche den Server nicht mehr über die normale Weboberfläche.
Es wird mir ständig angezeigt das die Verbindung verloren ist.
Über "http://127.0.0.1:3344/modules/front2/app/app.html/" erreiche ich den Server ohne Probleme.
Über mein Laptop im Wohnzimmer und der normalen Weboberfläche  hab ich das Problem nicht.
Ich vermute also irgend einen Fehler im Browser von Raspian?!

kennt Ihr das Problem?
Ich würde ungern den Pi neu aufsetzen.
Für Hilfe wäre ich Dankbar

gruss hadoko

Comments

  • Hast du dann für normale gui auch http://127.0.0.1:3344 verwendet? Damit ist er unabhängig.
    Ist das ein Pi 4 oder ein älteres Modell? Grundsätzlich lasse ich auf dem pi nicht die normale Oberfläche laufen da die deutlich mehr resourcen verbraucht bzw. verbrauchen kann. Könnte sein das hierdurch dann verzögerungen entstehen die zur Trennung führen. Wir haben ein timeout von ein paar sekunden (5 glaube ich) wenn während der zeit kein ping signal kommt trennt der server die Verbindung. Und wenn der Browser nicht hinterher kommt könnte das passieren.

    Du kannst alternativ mal den Repetier-Server Monitor für pi versuchen. Am pi 4 klappt der zumindest nur muss man eine app für Zeicheneingabe haben (oder eine Tastatur) an ein paar stellen. Ansonsten reicht klicken.
  • Hi,
    also ich nutze einen Pi 3 B+.
    ich gebe immer die normale IP an die mein Pi bekommen hat. Ich wusste nicht das ich den auch über die 127 auch erreiche.

    Was ich nicht verstehe ist das es immer funktioniert hat seit dem ich RS nutze und das ist seit letztem Jahr.
    Das Phänomenen tritt erst seit ca. 1,5 Monaten auf .
    Ich glaube mich zu erinnern das es seit den letzten 2 Updates erst so schlimm wurde.

    Kann ich irgendwo nachlesen wie ich den Monitor auf dem PI installiere.
    ich bin absolut kein Linux Kind. ich bekomme mit Anleitung aber fast alles hin

    MFG hadoko
  • Was mich beim Zugriff über "http://127.0.0.1:3344/modules/front2/app/app.html/", stört ist leider
    das ich nicht beide Drucker sehe die angeschlossen sind, sondern immer switchen muss.
    Und das ich die Seite nicht in Vollmodus setzten kann.
    Über das normale Web kann man den schönen Vollscreen Button drücken.
  • Repetier said:
    Hast du dann für normale gui auch http://127.0.0.1:3344 verwendet?

    gerade mal ausprobiert, gleiche Problem!
  • Die app.html Variante ist für Vollscreen gedacht und wird bei unserem Image auch so angezeigt. Man muss dazu chrome im kiosk modus starten.

    chromium-browser --disable-features=TranslateUI --app-auto-launched --disable-pinch --incognito --noerrdialogs --disable-suggestions-service --disable-translate --disable-save-password-bubble --disable-session-crashed-bubble --disable-infobars --touch-events=disabled --disable-gesture-typing --kiosk --check-for-update-interval=31536000 --app=http://127.0.0.1:3344/modules/front2/app/app.html &

    Das andere gui zeigt auch immer nur einen Drucker außer am Dashboard. Beim nächsten update kann man leichter zwischen den Druckern am touch screen wechseln und sieht besser welcher gerade aktiv ist. Einfach auf die Titelleiste klicken und man kann den Drucker wählen.

    Der Monitor für pi ist eine ausführbare Datei. Also nach download einfach mit chmod a+x Dateiname als Ausführbar markieren und starten. Hat auch einen parameter -fullscreen wenn du ihn über die Konsole startest.


  • Repetier said:
    Die app.html Variante ist für Vollscreen gedacht und wird bei unserem Image auch so angezeigt. Man muss dazu chrome im kiosk modus starten.

    chromium-browser --disable-features=TranslateUI --app-auto-launched --disable-pinch --incognito --noerrdialogs --disable-suggestions-service --disable-translate --disable-save-password-bubble --disable-session-crashed-bubble --disable-infobars --touch-events=disabled --disable-gesture-typing --kiosk --check-for-update-interval=31536000 --app=http://127.0.0.1:3344/modules/front2/app/app.html &

    Das andere gui zeigt auch immer nur einen Drucker außer am Dashboard. Beim nächsten update kann man leichter zwischen den Druckern am touch screen wechseln und sieht besser welcher gerade aktiv ist. Einfach auf die Titelleiste klicken und man kann den Drucker wählen.

    Der Monitor für pi ist eine ausführbare Datei. Also nach download einfach mit chmod a+x Dateiname als Ausführbar markieren und starten. Hat auch einen parameter -fullscreen wenn du ihn über die Konsole startest.


    Also das ist gerade wieder too much
    Ich möchte meinen Raspian als kleine  eigenständigen PC nutzen und den Browser auch zum surfen nutzen
    Auch nutze ich die Konsole ab und an.
    Das funktioniert doch im Kiosk Modus nicht oder?

    Also die "Repetier-Server Monitor-1.2.0-armv7l.AppImage" auf den Pi kopieren und dann,
    chmod a+x Repetier-Server Monitor-1.2.0-armv7l.AppImage?
    Dann funktioniert der Monitor?
    Sorry wie gesagt bin nicht so Linux fit.
  • Mit alt tab müsstest du weiterhin zwischen den apps wechseln können. Wegen full screen sind die Fensterelemente ja nicht sichtbar so. Ansonsten einfach fenster maximieren. Er passt sich ja an.

    Mit dem Appimage hast du richtig verstanden. sobald das x flag gesetzt ist kann man es über Datei explorer oder von der konsole heraus dann starten.
  • Hab den Befehl mit chmod jetzt eingegeben und bekomme das als Antwort:

    chmod: Zugriff auf 'Repetier-Server' nicht möglich: Datei oder Verzeichnis nicht gefunden

  • und wie starte ich die app dann von der Konsole bzw in Raspian?

  • Ok sehe da ist ein Leerzeichen drin. Dann muss man den Parameter in Anführungszeichen packen:
    chmod a+x "Repetier-Server Monitor-1.2.0-armv7l.AppImage"

    Das auch wenn du ihn ins autostart packst mit absolutem Pfad zu wo auch immer er steht.

    Von ssh aus must du vorher das Display richtig setzen:
    export DISPLAY=:0
    sollte passen denke ich. Dann aufrufen aber dazu muss der x server schon laufen. Einfacher ist es wenn du ihn in autostart packst da ist display bereits gesetzt wenn x server beim booten gestartet wird.
  • also die chmod hat jetzt ohne Fehler funktioniert.
    Tu mich aber gerade mit dem Autostart schwer.
    Hab bisschen gelesen und herausgefunden das ich eine Datei mit der Endung .desktop in das Verzeichis /etc/xdg/autostart einfügen soll?!
    Doch was füge ich jetzt alles in die Datei ein?

    [Desktop Entry]

    Type=Application

    Name=RSMonitor

    Exec=/home/pi/Downloads/"Repetier-Server Monitor-1.2.0-armv7l.AppImage"

    klappt das damit?

    Hab bisschen Angst mir mein System zu zerschiessen

  • Nein, log dich mit ssh ein und dann
    nano /home/pi/.config/openbox/autostart

    Vor dem
    chromium-browser --disable-features=TranslateUI --app-auto-launched --disable-pinch --incognito --noerrdialogs --disable-suggestions-service --disable-translate --disable-save-password-bubble --disable-session-crashed-bubble --disable-infobars --touch-events=disabled --disable-gesture-typing --kiosk --check-for-update-interval=31536000 --app=http://127.0.0.1:3344/modules/front2/app/app.html &
    packst du eine # damit sie nicht ausgeführt wird und dahinter schriebst du
    "/home/pi/Downloads/Repetier-Server Monitor-1.2.0-armv7l.AppImage" --fullscreen &

    danach
    sudo reboot
    und er sollte es starten und chromium nicht mehr.
  • edited November 23
    Repetier said:
    Nein, log dich mit ssh ein und dann
    nano /home/pi/.config/openbox/autostart

    Vor dem
    chromium-browser --disable-features=TranslateUI --app-auto-launched --disable-pinch --incognito --noerrdialogs --disable-suggestions-service --disable-translate --disable-save-password-bubble --disable-session-crashed-bubble --disable-infobars --touch-events=disabled --disable-gesture-typing --kiosk --check-for-update-interval=31536000 --app=http://127.0.0.1:3344/modules/front2/app/app.html &
    packst du eine # damit sie nicht ausgeführt wird und dahinter schriebst du
    "/home/pi/Downloads/Repetier-Server Monitor-1.2.0-armv7l.AppImage" --fullscreen &

    danach
    sudo reboot
    und er sollte es starten und chromium nicht mehr.
    nano /home/pi/.config/openbox/autostart
     Also diese Datei existiert bei mir nicht
  • Pfad ist aber richtig. Nutzt du nicht unser image? In den images von pi foundation gibts das nicht. Da musst du autostart anders umsetzen denn ich denke nicht das die openbox verwenden. Weiß aber dafür die Lösung nicht. Einfach mal nach autostart für den Desktop suchen.
Sign In or Register to comment.