Repetier reagiert sehr träge mit 2 Druckern

Hallo.
Bin neu hier und bräuchte eure Hilfe.
Habe heute Repetier ausprobiert um meine 2 Drucker mit einem Raspberry steuern zu können.
Bis jetzt nutze ich astrobox.

Nun mein Problem:
Pi 4 4GB
repetier pro 0.94.3
Drucker 1: Prusa i3 clone mit marlin 2.0
Drucker 2: Tronxy x5sa pro

Drucker wurden problemlos erkannt und eingerichtet.
Wenn ich nur einen Drucker mit usb anschließe, dann funktioniert alles einwandfrei
Solbald ich den 2. (egal welcher zuerst angesteckt ist) anschließe, reagieren die drucker sehhhhhrrrr zeitverzögert wenn überhaupt.

der 2. angesteckte drucker lässt sich manchmal garnicht bediehnen.

Habt ihr da einen idee?

Lg Tom

Comments

  • Das ist eher unüblich. Du solltest dir bei beiden dann mal die Konsole ansehen und alles aktivieren da wenn nichts sichtbar ist. Ein verdächtiger ist beim pi immer Stromversorgung. Wenn beide Strom über usb beziehen könnte es sein das es zu viel wird und linux ständig einen oder beide trennt. Wenn das so ist hilft dir
    https://www.repetier-server.com/knowledgebase/undervoltage-and-throtteling-of-pi/
    sicher weiter. Insbesondere das 5V abklemmen sollte hier dazu führen das kein Strom mehr gezogen wird.

    Wenns was anderes ist poste mal was im log (konsole) so steht wenn er so langsam wird. Sollte daraus leicht ersichtlich sein.
  •  Hallo.
    Nach unzähligen probieren auf pi 3b+ und pi4 4Gb keinen lösung

    Log:
    Mesg:15:03:42.281: Warning: Communication timeout - resetting communication buffer.
    Mesg:15:03:42.281: Connection status: Buffered:102, Manual Commands: 6, Job Commands: 0
    Mesg:15:03:42.281: Buffer used:102 Enforced free byte:25 lines stored:6
    Mesg:15:03:42.281: Warning: Too many timeouts without response - disabling timeout message!
    Mesg:15:03:42.282: Advice: If communication does not recover try adding usb reconnect on timeout in printer settings!
    Mesg:15:03:42.282: This helps in case it is the serial driver that hangs.

    das passiert auf beiden druckern
  • Ist definitiv der Prusa clone.
    Der Tronxy druckt tadellos.

    Prusa i3 clone
    Gt 2560 A+ Board
    Marlin 2.0
    Baudrate: 250000
    DTR, RTS: Tief zu hoch.

    Der Drucker reagiert nur manchmal.
    Auch ,,bootet" er dazwischen gerne mal neu! Marlin logo wird angezeigt.

    Wenn ich ihn von USB trenne, dann läuft er einwandfrei.
    Unter Astrobox ist auch alles ok.
    Wollte eigentlich von Astrobox auf Repetier unsteigen, aber das wird anscheinend nix.


  • Send:17:09:32.899: M117 ETA 17:14:57 day 3
    Recv:17:09:32.913: //####checkSum error expect:0x7b,actual:0x15!str:M117 ETA 17 14 57 day 3
    Recv:17:09:32.914: ok N:3229
    Recv:17:09:33.387: Resend:3230
    Recv:17:09:33.399: //callback_pf error
    Send:17:09:33.415: N3232 G1 F965 X155.2 Y174.8 E489.17625
    Recv:17:09:33.423: wait

    was bedeuten die fehlermeldungen?
  • Die Fehlermeldungen kommen von der Firmware. Ehrlich gesagt keine Ahnung was callback_pf error sein soll. Das andere mit checkSum ist ein Prüfziffernfehler. Wobei da gar keine Prüfziffer gesendet wird bei M117 weil ältere Marlin Versionen das nicht verstanden. Normal kann man so was ignorieren wenn die Firmware danach nicht meckert.

    Beim Prusa clone hast du mit DTR hoch zu tief vermutlich eingestellt das er beim verbinden normal den Drucker neu startet. Die Frage ist daher was ist die Ursache? Steht normal im log. Da steht dann Reset oder Watchdog oder Brown out als Ursache. Wenn linux die Verbindung trennt kann es daher kommen. Wenn du das Trennen bei Timeout im Server aktiviert hast kann es auch daran liegen. Wobei der Server da versucht keinen Reset auszuführen.

    Hast du als Firmware auch Marlin eingestellt? Wenn da noch repetier steht wird er eh nichts verstehen.
  • Ja firmware ist marlin.
    Der callback error usw. umisr aber von meinem tronxy.
    Hab dort aber auch marlin eingestellt obwohl der das chitu board hat.
  • Ach ja der prusa clone verbindet sich ausser mit oben genannten einstellungen nicht mit dem server!
    Nur bei 250000 hoch zu tief wirds was.
    Komisch ist dass er manchmal ein paar befehle durxhführt.
    Hab gerade probiert zu drucken, da heizt er das hotbed auf und bleibt mittendrunter hängen.
    Da hilft nurmehr drucker und server abdrehen.

    Der tronxy druckt trotz der fehlermeldungen ganz normal.
    Hat das chitu board eigentlich marlin?
  • Boards haben die Firmware die man aufspielt. Das können durchaus unterschiedliche sein, also schwer zu sagen aber Marlin ist am häufigsten. Sieht man normal wenn man M115 sendet auch wenn viele den Firmware Namen ändern.

    Nur ein paar Befehl eist natürlich unbefriedigend. Und gleicher pi mit Astroprint hat da keine Probleme mit gleichen Einstellungen? 
    Was nutzt er eigentlich als serial driver?
    lsusb
    sollte die Geräte zeigen. Am besten dabei den Tronxy abgozogen haben sonst weiß man nicht welcher was nutzt.
  • Drucke mit dem prusa clone seit 3 jahren mit astrobox.
    Keine probleme.
    Serial driver?
    Hilf mir mal
  • Auch wenn quasi alle Seriellen geräte am usb erkannt werden so gibt es doch unterschiedliche Treiber in Linux. lsusb listet alle usb Geräte. Was wohl auch anders ist , ist die Linux version. Wir nutzen die aktuelle Version mit Kernel 5.4.51 - Astroprint wird bei 3 Jahren alter wohl eher 4.xx nutzen. Wenn das Problem im Linux usb->serial Treiber entsteht kann es also auch einfach an der Linux version liegen.

    Prinzipiell kannst du auf dem Astroprint linux auch mal den Server zusätzlich installieren und verbinden (astrobox sollte aber nicht versuchen sich zu verbinden). Wenn es da dann Problemlos klappt ist klar das es an der Linux version liegt.
  • So zum laufen gebracht!!
    Aus einem anderen Post die richtigen settings eingegeben und nun scheints zu funktionieren.

    Folgendes Problem hab ich jedoch, tritt bei beiden druckern auf:

    Wenn ich den Druck abbreche, heizen bed und hotend trotzdem weiter.
    Nach erreichen der solltemperatur wird angezeigt, dass der Druck fertig ist, jedoch werden Hotbed und Hotend weiter beheizt.

  • Hallo Tomtom kannst du trotzdem mal schreiben was du falsch hattest. Das wird anderen Lesers helfen, die genau über diesen Thread hier stolpern.
  • Habe die verbindung manuell eingestellt.
    Usb by path
    Rts, Dtr Hoch zu tief.
    Damit bootet er nicht mehr neu
  • Sorry ALLES ZURÜCK!!
    Hat leider auch nicht den erhofften Erfolg gebracht!!!

    Jetzt lassen sich beide plötzlich nicht mehr ansprechen!!

    Ich glaub das wars für mich mit Repetier!
    Danke für die Hilfe aber ich bekomms einfach nicht stabil zum laufen.
    Mir hat zwar die GUI und Bedienung sehr gut gefallen, ebenso wie dass steuern mehrerer Drucker über einen Pi.

    Aber leider ohne Erfolg.
    Nehme mir glaub ich die 3. Astrobox lizenz, die funktioniert out of the box.

    Danke jedefalls
  • edited November 4
    Ich würde noch nicht aufgeben. Ich hatte auch Probleme, als ich 2 Drucker in Betrieb nehmen wollte. Während ein Drucker mit Repetier-Firmware recht "unkompliziert" war. War ein Drucker mit Marlin 2 recht hartnäckig. So hatte ich Anschlüsse in der Weboberfläche von
    dev/serial/by-id/usb-marlinfw.org_Marlin_USB_Device_Und eine Menge Zahlen und Buchstaben
    oder

    /dev/serial/by-path/platform-3f980000.usb-usb-0:1.3.4:1.0

    Aber diese Auswahl hat mir niemals geholfen. Ich habe dann alles mögliche versucht. Bei mir hat dann
    /dev/ttyACM0
    geholfen. Das muss aber bei dir nicht so sein. Es kann auch eine andere Bezeichnung haben, wie "dev/ttyAMA0" oder "dev/tty/AMA1". Zudem hatte ich bei mir den Speed der Schnittstelle auf 115200 verringert. Diese Geschwindigkeit kann ebenfalls ein Problem bei Marlin 2 sein.

    So einfach aufzugeben, wäre schon schade.  ;)
  • So jetzt liefen beide wieder mal.
    Also druck gestartet!
    Und siehe da, plötzlich bleiben beide syncron stehen!!
    Is mir zu blöd!
    Gibts ja nicht dass das nicht stabil läuft?
    Nach 1/2 stunde problemlos drucken auf beiden ist dann plötzlich ende!
    Is echt unspassig.
    Kenn ich leider so nicht.
    Da schieb ich doch lieber wieder sd karten im kreis.
    Bin mit meinem latein am ende.
    Keine nerven mehr!!
  • Nur um sicher zu sein - hast du im server im Blitz menü mal getestet ob der pi zwischendurch Spannungsprobleme hatte. Ist die häufigste Ursache für allerhand unerklärlicher Probleme. Daher haben wir dazu sogar einen eigenen faq Eintrag auf unserer Homepage und einen Hinweis auf der Downloadseite.
Sign In or Register to comment.