How can I adjust the "extrusion multiplier"?

I have an issue where my new nozzles are not pushing as much filament through as the old nozzle did.  I need to slightly increase the "extrusion multiplier" setting but can not find it in the CuraEngine slicer settings inside Repetier-Host.  Can someone tell me where I can find this setting, please?  Thanks!


  • Actually the right pace is to change steps per mm for your extrduer in firmware since this is hardware related.

    In CuraEngine it is a filament parameter and called Flow. But that is normally only used to change different material behaviour.
  • Maybe at this point, it is just something I need to do for the type of filament I'm using (though it's nothing special, 1.75mm PLA Black Inland)  Where exactly is that "Flow" parameter located inside the Repetier-Host software?  I mean I know it's in the CuraEngine settings/config...  Just don't know exactly where it's at.

    OK Do you happen to know what the setting is called exactly in the firmware?  It seemed to work fine when I had on the old nozzle (on the left, which I think was a 0.6 now).  The new nozzle (on the right) is defiantly a 0.4 nozzle (printed on the side).

    The current print leaving gaps...

    The links below show the text of my currently used and modified firmware.  I have a RepRap Guru DIY Prusa i3 v2 printer I built.  I'm not sure if that matters but I wanted to give you as much info as possible.




  • New nozzle shoul d in deed not change steps per mm. But it increases pressure required for same speed so you might get more slip and maybe also more temperature to make it flow easier.

    In CuraEngine configuration is only one page for filament settings and the second value is called flow for oyur adjustment.

    In firmware it is this:
    1. /**
    2. * Default Axis Steps Per Unit (steps/mm)
    3. * Override with M92
    4. * X, Y, Z, E0 [, E1[, E2...]]
    5. */
    6. #define DEFAULT_AXIS_STEPS_PER_UNIT { 80, 80, 4000, 500 }
  • edited October 2020
    Humm...  Apparently judging from what you just posted the firmware (though should be right to start with) can just be left alone and you add an M92 line to the "Run before job" in the Repetier-Server Event Dependent section under the printer's G-Codes section.

    Since my printer does not seem to be pushing out enough filament and my current value for the Steps Per Unit on the extruder is 500...  For testing, should I tell it to try 600 or 400?  I'm assuming I would try to use 600 to tell it that it takes more steps to achieve what it thinks is the equivalent of 1 (~1mm I guess).

    Also...  Using the flow rate to manipulate the situation, I do get better results when decreasing the flow rate...

  • looks like nozzle diameter is not correct in slicer.
    if its set for the old (bigger) nozzle it will not give correct result for the new (smaller) nozzle
  • Yeah...  so I just figured out my issue...
    It seems that even though it has #define DEFAULT_AXIS_STEPS_PER_UNIT { 80, 80, 4000, 500 } in my firmware, at some point a M92 command was issued and I guess followed by a M500 (to make it stick).  That command was M92 X80.00 Y80.00 Z4000.00 E90.00 and the whole time (before the nozzle and at the time firmware upgrade) I was using an axis steps per unit for the extruder of 90!  So, I'm going to update the firmware again and reflash so the issue is resolved at the root of the problem.  I'll post an update soon.
  • edited October 2020
    OK ... heck, doing even more digging I checked the values I saved in a text file before the f/w upgrade (using M503)...
    0:16:20.473: N11 M503
    0:16:20.479: echo: G21 ; Units in mm
    0:16:20.480: echo: M149 C ; Units in Celsius
    0:16:20.483: echo:Filament settings: Disabled
    0:16:20.484: echo: M200 D3.00
    0:16:20.484: echo: M200 D0
    0:16:20.484: echo:Steps per unit:
    0:16:20.488: echo: M92 X80.00 Y80.00 Z4000.00 E90.00
    0:16:20.488: echo:Maximum feedrates (units/s):
    0:16:20.488: echo: M203 X250.00 Y250.00 Z2.00 E22.00
    0:16:20.492: echo:Maximum Acceleration (units/s2):
    0:16:20.492: echo: M201 X1000 Y1000 Z5 E1000
    0:16:20.496: echo:Acceleration (units/s2): P<print_accel> R<retract_accel> T<travel_accel>
    0:16:20.496: echo: M204 P500.00 R500.00 T750.00
    0:16:20.500: echo:Advanced: S<min_feedrate> T<min_travel_feedrate> B<min_segment_time_ms> X<max_xy_jerk> Z<max_z_jerk> E<max_e_jerk>
    0:16:20.503: echo: M205 S0.00 T0.00 B20000 X20.00 Y20.00 Z0.40 E5.00
    0:16:20.503: echo:Home offset:
    0:16:20.508: echo: M206 X0.00 Y0.00 Z0.00
    0:16:20.508: echo:Material heatup parameters:
    0:16:20.509: echo: M145 S0 H180 B70 F255
    0:16:20.509: M145 S1 H225 B100 F255
    0:16:20.510: echo:PID settings:
    0:16:20.511: echo: M301 P22.20 I1.08 D114.00
    0:16:20.511: ok
    And the current values I'm using...
    Recv:16:25:06.857: N2896 M503
    Recv:16:25:06.858: echo: G21 ; Units in mm (mm)
    Recv:16:25:06.858: echo: M149 C ; Units in Celsius
    Recv:16:25:06.859: echo:; Filament settings: Disabled
    Recv:16:25:06.859: echo: M200 D1.75
    Recv:16:25:06.859: echo: M200 D0
    Recv:16:25:06.861: echo:; Steps per unit:
    Recv:16:25:06.861: echo: M92 X80.00 Y80.00 Z4000.00 E80.00
    Recv:16:25:06.866: echo:; Maximum feedrates (units/s):
    Recv:16:25:06.867: echo: M203 X250.00 Y250.00 Z2.00 E22.00
    Recv:16:25:06.870: echo:; Maximum Acceleration (units/s2):
    Recv:16:25:06.871: echo: M201 X1000.00 Y1000.00 Z5.00 E1000.00
    Recv:16:25:06.875: echo:; Acceleration (units/s2): P<print_accel> R<retract_accel> T<travel_accel>
    Recv:16:25:06.875: echo: M204 P500.00 R500.00 T750.00
    Recv:16:25:06.880: echo:; Advanced: B<min_segment_time_us> S<min_feedrate> T<min_travel_feedrate> X<max_x_jerk> Y<max_y_jerk> Z<max_z_jerk> E<max_e_jerk>
    Recv:16:25:06.881: echo: M205 B20000.00 S0.00 T0.00 X20.00 Y20.00 Z0.40 E5.00
    Recv:16:25:06.882: echo:; Home offset:
    Recv:16:25:06.887: echo: M206 X0.00 Y0.00 Z0.00
    Recv:16:25:06.887: echo:; Material heatup parameters:
    Recv:16:25:06.887: echo: M145 S0 H180 B70 F255
    Recv:16:25:06.891: echo: M145 S1 H225 B100 F255
    Recv:16:25:06.891: echo:; PID settings:
    Recv:16:25:06.891: echo: M301 P12.55 I0.55 D71.15
    Recv:16:25:06.892: echo: M304 P8.82 I1.56 D33.22
    Recv:16:25:06.893: ok

    DEAR GOD!  ALL THAT TIME (A LONG TIME) that I have been using my printer my firmware (or settings in the printer at some point) were thinking it had a 3MM Nozzle!!  Going through it this time I was apparently checking my values...  I set them like they should have been set (D1.75) and now my printer is REALLY not calibrated!...

    It's really interesting how it was producing such great prints before.

    So now everything I'm trying to tweak is based off of a 3mm nozzle.  Here are my test so far...

    You can't really tell it in that image (I need to have a light under the paper) but there are still gaps in the top right one.  I fell like I'm going to need to jack up the flow to 150% or more to get the results I want.  I feel like that's just really wrong.

    Any more suggestions?

  • edited October 2020
    what you mean with 3mm respectively 1.75 mm is filament diameter , not nozzle diameter.

    follow this to calibrate your extruder :

    set flow rate to 100% to do this!!

  • RAyWB said:
    what you mean with 3mm respectively 1.75 mm is filament diameter , not nozzle diameter.

    follow this to calibrate your extruder :

    set flow rate to 100% to do this!!

    Sorry there was a little typo there.  Any time I talked about 1.75mm and 3mm I was talking about the filament type setting.  You can see these settings by using the command `M503`.  My results were as shown in my previous post.  They used to be "echo: M200 D3.00" (D3) and now they are "echo: M200 D1.75" (D1.75).  1.75 is the correct filament size value that should have been used in the first place, and it's the one I'm using now. 
  • @RAyWB first of all, thanks!  That website I have visited a few times but never viewed that page you referenced.  It put a LOT of things in perspective for me!  Now that I know how to correctly calibrate the printer and more importantly see what is actually being extruded, I can check for other issues (not just my Steps per Millimeter Value).  The whole process makes complete sense and I'm actually kind of ashamed I didn't think to do these simple steps and math in the first place.

    Well, when calibrating the printer's extruder steps I had one heck of a time.  It was just wrong every time I made a change to the steps/mm value.  Then I just stopped changing values and ran 3 tests to see how much filament was used each time.  Funny thing, it was different, VARY different!

    Now I'm guessing I have some major slippage with the feeder.  I think it might be the fact I'm just trying to send to much filament through a smaller hot end with the same temp as my larger hot end before.  I'm going to try and raise the temp from 180 to 190-200 and/or slow down the speed at which it tries to push it out.
  • To be honest, I think in the end it was as simple as I now have a smaller nozzle (0.4) than I did before (possibly 0.6).  I just needed to adjust my normal temp on the extruder from 180 to 215.  The PLA spool actually says temps ~215-230, but I just never really needed to go above 180 (I guess because of a larger nozzle).

    It seems to be much more stable now.  Thanks for all the advice.
Sign In or Register to comment.