WLAN verbindung nicht möglich.

edited October 2020 in Bug Reports
Guten Tag,

ich habe das Problem das ich meinen Repetier Server nicht mit meinem WLAN verbinden kann.
Die SSID wird angezeigt (Mist, WLAN-Kabel zu kurz.) nach Eingabe des Passworts wird aber keine Verbindung hergestellt. Das Passwort wurde direkt aus der Weboberfläche des Routers Kopiert und dann eingefügt, ein Tippfehler ist damit ausgeschlossen.

Versuche ich den Repetier-Server mit meinem Gast-WLAN zu verbinden (SSID: Herzlich Willkommen) klappt die Verbindung. Stört sich der Repetier Server eventuell an dem Komma und Punkt in der SSID?

Verwendet wird eine FritzBox 6490 Cable mit FritzOS 07.20.
WLAN ist in beiden Netzen mit WPA2 (CCMP) verschlüsselt.

Ich benutze Repetier Server Pro 0.94.3 auf einem Raspberry Pi 3 Model B+.

Wo könnt der Fehler liegen das ich keine WLAN Verbindung zum WLAN "Mist, WLAN-Kabel zu kurz." herstellen kann?

Vielen Dank schon einmal für Unterstützung bei der Fehlersuche.

Comments

  • Ja kann mir vorstellen das die SSID ein Problem ist. Der Name wechselt hier über skripte und externe Programmaufrufe und enthält alles um Probleme zu verursachen also Komma Leerzeichen und Punkt. 

    Ich hab grad mal versucht manuell die Befehle zu schicken. Da hat er die SSID korrekt in /etc/wpa_supplicant/wpa_supplicant-wlan0.conf eingetragen. Kannst du mal per ssh
    cat /etc/wpa_supplicant/wpa_supplicant-wlan0.conf
    eingeben kurz nachdem du die Verbindung herstellen willst. Must den richtigen Zeitpunkt erwischen da er die Datei evtl wieder löscht. Frage ist ob ssid und passwort es da rein schaffen oder nur ein Teil.

    Interessant ist auch /usr/local/Repetier-Setup/etc/server.conf wo die vom Server gemeldeten Parameter zwischengespeichert werden. Also auch da nachsehen wie weit die SSID da korrekt drin steht.

    Ich gehe hier davon aus das es ein aktuelles Image ist, da wir früher mal einen anderen Netzwerkmanager nutzten.
  • edited October 2020
    Vielen Dank für die Antwort. Ich habe wie beschrieben versucht mich zu verbinden und dann den ssh Befehl ausgeführt.

    Die SSID wurde korrekt übernommen, aber im Passwort ist ein Fehler. Das Passwort beginnt mit Il$#2************ daraus wurde Il02*********. Scheint so als ob es ein Problem mit dem $ und # Zeichen im Passwort gibt.

    pi@Repetier-Server:~ $ sudo cat /etc/wpa_supplicant/wpa_supplicant-wlan0.conf
    ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
    update_config=1
    country=DE
    network={
        ssid="Mist, WLAN-Kabel zu kurz."
        psk="Il02O************"
        
    }

    Der zweite Befehl liefert folgendes:

    pi@Repetier-Server:~ $ sudo cat /usr/local/Repetier-Setup/etc/server.conf
    SSID=RepetierServer
    WLAN_SSID_HIDDEN="false"
    PASSWORD=12345678
    WLAN_SSID="Mist, WLAN-Kabel zu kurz."
    WLAN_PASSWORD="Il02O*******"
    WLAN_PASSWORD_METHOD="wpa-psk"
    CHANNEL=9
    WLAN=wlan0
    WLAN_HOTSPOT=wlan0
    COUNTRY=DE
    AP_ACTIVE="false"
    ETH_CON="eth0"
    ETH_4_MODE="auto"
    ETH_4_STATIC=""
    ETH_4_DNS=""
    ETH_4_GATEWAY=""
    ETH_6_MODE="auto"
    ETH_6_STATIC=""
    ETH_6_DNS=""
    ETH_6_GATEWAY=""
    WLAN_SSID="Mist, WLAN-Kabel zu kurz."
    WLAN_SSID_HIDDEN="false"
    WLAN_4_MODE="auto"
    WLAN_4_STATIC=""
    WLAN_4_DNS=""
    WLAN_4_GATEWAY=""
    WLAN_6_MODE="auto"
    WLAN_6_STATIC=""

    Ich würde ungern mein WLAN Passwort ändern und in sämtlichen Geräten neu einrichten. Gibt es eine Möglichkeit das Problem mit $ und # anders zu beheben?

    Ich gehe hier davon aus das es ein aktuelles Image ist, da wir früher mal einen anderen Netzwerkmanager nutzten.

    Was genau ist mit Image gemeint? Installiert ist aktuell Repetier Server Pro 0.94.3. Die Installation erfolgte Anfang August 2020.

    Herzlichen Dank für die Unterstützung.

  • Ok das Dollar Zeichen ist das eigentliche Problem. Das sind Bash Skripte und variablen werden durch $ eingeleitet und in dem Fall mit # beendet. Er hält es für eine Variable. Muss mal sehen ob es eine möglichkeit gibt so was beim Schreiben zu escapen. Als Notlösung über ethernet per ssh verbinden. In der weboberfläche AP auf nie aktivieren stellen.
    Dann in /usr/local/Repetier-Setup/etc/server.conf dem $ ein \ voranstellen.
    sudo nano /usr/local/Repetier-Setup/etc/server.conf
    danach
    sudo /usr/local/Repetier-Setup/bin/manageWifiAccess connect

    eingeben und dann sollte er wlan verbinden und hoffentlich so lassen. Sobald was an der Konfiguration geändert wird könnte er es wieder falsch verstehen. Als harte Lösung kannst du dann aber  /usr/local/Repetier-Setup/bin/manageWifiAccess umbenennen. 

    Fürs nächste image werde ich versuchen das $ automatisch zu escapen damit es für alle mit $ direkt klappt.

  • Vielen Dank für deine Antwort.

    Ich bleibe dann erstmal beim LAN Anschluss und hoffe das es mit der nächsten Version dann so klappt. Bin nicht so fit was die ganzen SSH Sachen anbelangt.
  • Kein Problem. Arbeite gerade daran die richtig zu escapen. Bis in die Konfiguration klappts so weit. Jetzt muss wpa_supllicant es nur noch verstehen:-)
  • Um mal eines anzumerken
    Beim Passwort und Komplexität, geht es meist nicht um die tatsächliche Komplexität aus Sicht eines Menschen, sondern um eine reine mathematische Komplexität. Und wenn wir eins Wissens, dann ist es das. Maschinen sind richtig langsam, wenn die Zahlen groß werden. Also müssen Passwörter nicht unmerkbar und unknackbar aus Sicht eines Menschen sein. Sondern sie müssen einfach nur lang sein. Denn das gängigste Mittel, um Passwörter zu knacken ist es zu raten. Dazu werden Wortlisten oder die Brechstange verwendet. Die Brechstange ist aber auch nur Brute Force, also das Ausprobieren jedes möglichen Zeichens. Und je länger ein Passwort ist, umso länger braucht eine Maschine. Also nicht die Sonderzeichen machen ein Passwort sicher, sondern die Länge. Natürlich erhöhen die Zeichen, die ausprobiert werden müssen, die Laufzeit nochmals. Aber das kannst du durch eine Stelle mehr kompensieren.

    Wenn ein Passwort aus anderen technischen Gründen ausgelesen werden kann, dann nützt dir die größte Komplexität (aus Sicht eines Menschen) nichts. Denn dann ist das Passwort in Sekunden geknackt. Egal wie komplex du es fandest.
  • Hallo,
    ich habe gerade auf Repetier-Server Pro 1.0.2 upgedatet, WLAN Funktioniert leider immer noch nicht. Wurde das schon gefixt oder noch nicht?
  • Das passworthandling ist teil des image. Hab das im neuen image für 1.0.2 geändert. Der serve nutzt nur die angebotenen Skripte.
  • edited January 29
    Also ich verzweifle gerade...

    Ich habe mir letzte Woche die Pro Version gekauft und bekomme einfach keine dauerhafte WLAN Verbindung hin!
    Teilweise hat die Verbindung funktioniert... Leider seit 4h nicht mehr... anfängliches Problem war, dass meist nach einem Neustart kein WLAN mehr verfügbar war.

    Fritz!Box 7590 im 2,4 gHz Netz 

    Ich habe bereits in /var/lib/Repetier-Server/database/ beide Dateien gelöscht, den AP deaktiviert, Festen Kanal 6 und 9 eingestellt. Trotzdem bekomme ich nach einem Neustart einfach keine Verbindung mehr aufgebaut! Woran kann es liegen? Was kann ich machen?

    Aktuell bekomme ich zwar die Netzwerke angezeigt, bekommen jedoch überhaupt keine Verbindung mehr aufgebaut.


  • Benutzt du das aktuelle image? Da haben wir einen fix für ein Problem das mit Fritzbox häufiger passiert - zumindest bei uns. Der Linux Treiber hängt dann und muss neu gestartet werden. Wenn wir dies machen schreiben wir das in /tmp/wifi-restarts.log

    Deutschland als Region eingestellt? Nur dann erlaubt er auch die Nutzung alle Frequenzen.

    Zur analyse solltest du zusätzlich per Kabel verbinden. Dann kannst du dich darüber einloggen und z.b.
    iwconfig
    eingeben um zu sehen wie der status ist und
    sudo cat /etc/wpa_supplicant/wpa_supplicant-wlan0.conf
    um die Konfiguration des wifi zu sehen. Letztendlich machen wir nichts anderes als diese Konfigurationsdatei für Linux zu schreiben das sich dann damit automatisch verbindet - zumindest wenn AP auf nie steht. Sonst könnten wir auch auf AP konfiguration wechseln.

    mit tail -2000 /var/log/syslog
    kannst du auch noch Betriebssystem log ansehen und sehen ob da drin steht was schief geht wenn wpa sich verbindet.
  • /tmp/wifi-restarts.log
    -> muss ich mir mal anschauen

    Deutschland als Region eingestellt?
    -> Ja und AP-Modus deaktiviert

    Leider habe ich das Problem immer noch... Manchmal ist noch nicht mal eine neue Verbindung möglich..
    Aktuell habe ich neu aufgesetzt udn das Problem tritt sporatisch auf.


  • Frage, wann werden die ekletanten nervigen WLAN Probleme gefixt. Das Nervt langsam.
    Ständig verliert er die WLAN Verbindung, Da liegt ja offensichtlich wohl ein Problem hier, siehe Thread.
    Hab normalen Pi 4 mit Fritzbox. 60€ sind viel Geld wenn das ganze nicht läuft ...
  • Mit dem letzten image kann man die wlan steuerung über den server komplett deaktivieren. Einfach die korrekte wpa_supplicant einstellung in /boot kopieren und diese wird von Linux genutzt. Dann verstellt der server nichts. Dennoch wird es passieren können das Probleme auftreten, oder auch nicht. Das kommt immer auf die Ursache des Problems an und die sind bei WLAN leider vielfältig. Empfangsprobleme können wir nicht lösen. Wenn das Land falscheingestellt ist und router einen Kanal nutzt der nicht freigegeben ist geht auch nichts. Im büro haben wir immer wieder Probleme mit unserem Fritzrouter obwohl er nur 1m weiter steht. Da scheint sich der Treiber aufzuhängen und wir haben daher sogar einen neustart des Treibers für den Fall programmiert. Hängt dann eine weile und dann geht es wieder. Aber wir haben den Linux WIFI Treiber nicht geschrieben und wissen nicht warum der hängt. Bei mir zuhause mit einem anderen Router gibt es das Problem nicht und alles ist stabil.
    Sobald was bekannt wird was wir verschulden, fixe ich es immer gerne.

    Alternativ kannst du das original pi image nutzen und dort den server installieren. Dann ist wifi tab sogar komplett ausgeschaltet weil wir nicht mal anzeigen können was eingestellt ist.

    /usr/local/Repetier-Setup/bin/monitorSyslog
    ist übrigens das Monitoprogram das gff. den Treiber neu startet. Du kannst es testweise umbenennen und neu booten und sehen ob es besser wird. Bei uns bedeutet es das wlan nie wieder kommt. Mit dem skript kommt es immerhin nach einem zusammenbruch zurück.
Sign In or Register to comment.